Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11448

FirstClass Authentication does not hold settings and has cosmetic and info leakage issues

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.8.3, 1.9
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      MAMP, FirstClass (authentication only), OS X 10.4.10
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      FirstClass authentication module does not hold onto settings and has cosmetic issues solved below. This issue plagued us in 1.8 and is still here.

      Our issues with FirstClass authentication were resolved with fix from Jonathon Dickmann's post on this issues. See http://moodle.org/mod/forum/discuss.php?d=68767&parent=345561

      Issue not as emergent as originally proposed. Make sure admin has instructions to turn command line access on for ALL users in Firstclass for this to work. See post above for critical additions in order for authentication to work moodle must hold onto the config setting which it doen not for this version and now with 1.9 too.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                skodak Petr Skoda
                Reporter:
                dtrockman Dan Trockman
                Tester:
                Nobody
                Participants:
                Component watchers:
                Carlos Escobedo, Mark Nelson
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Oct/07