Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11475

Adding support in ajaxlib.php for yui_container_core YUI library

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Won't Fix
    • Affects Version/s: 1.8.2, 1.8.3, 1.8.4
    • Fix Version/s: None
    • Component/s: JavaScript
    • Labels:
      None
    • Environment:
      All environements
    • Affected Branches:
      MOODLE_18_STABLE

      Description

      short form keys for requiring js libraries miss container_core.js library which may be needed in some cases as dependencies of other libs.

      Should just add line :

      'yui_container_core' => '/lib/yui/container/container_core-min.js',

      in ajaxlib.php
      at line §83

        Attachments

          Activity

            People

            Assignee:
            moodle.com moodle.com
            Reporter:
            vf Valery Fremaux
            Participants:
            Component watchers:
            Andrew Lyons, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: