Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11502

HTML files will not display if >100KB and filteruploadedfiles setting is set to "HTML files only" or "All files"

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Duplicate
    • 1.8.2
    • None
    • Filters
    • None
    • RH AS 4, Apache 2.2, PHP 5.2.4, eAccelerator 0.9.5.2
      4GB RAM
    • MySQL
    • MOODLE_18_STABLE

    Description

      Teacher reported that when linking to certain HTML files, the files would not display when clicked on. After a great deal of troubleshooting, we determined that if the HTML files were smaller than 100KB, than they would display. However, if the file is 100KB or larger, than the file will not display. Based on a hunch and after reviewing the apache logs (which did not yield any helpful information), I changed the setting in Filter Settings for filteruploadedfiles to "None" instead of "HTML files only" or "All files".

      Is this a known issue?

      So here is one additional relevant factor – last week, it worked just fine on a stock RH AS 4, with RH RPMs for Apache 2.0, PHP4, GD, etc, (without eaccelerator). We upgraded to this custom build LAMP because performance after upgrading to 1.8.2 with the Red Hat RPMS is abysmal (when it worked just fine with 1.6.1).

      Attachments

        Issue Links

          Activity

            People

              skodak Petr Skoda
              mcksean Sean McKay
              Nobody Nobody
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Laurent David, Raquel Ortega, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: