Moodle
  1. Moodle
  2. MDL-11507

two undefined indexes during restore

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.11, 1.9.7
    • Fix Version/s: 1.8.12, 1.9.8
    • Labels:
      None
    • Environment:
      server windows to server macosX
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      The source environment was Moodl 1.8.2+
      I created a very simple and quite empty course.
      I created two categories ("produttore" and "cav") and I had one user per category enrolled into my quite empty course.

      I made a backup of this course requiring user.

      I went to a different server.
      I made a CVS update (half an hour ago, saturday September 29 8:00 a.m. italian time).
      I called the page "notification"
      and I restored the course coming from the different server backup.

      Attached is the error I got.

        Gliffy Diagrams

        1. Immagine 1.png
          37 kB

          Activity

          Hide
          Daniele Cordella added a comment -

          Hei Eloy
          nice to see my post is in your hands.
          Now that I know this, I can add more information.
          The source server is the one of andreabix (MediaTouch). So, if you need to know the OS, the last update time, the Moodle release or whatever, ask him.
          The bug in the restore was with a db module.
          My original course is still on andreabix server. So go to see it if you need this. Also the backup is still on his server.
          I am always available for further information.
          Ciao.

          Show
          Daniele Cordella added a comment - Hei Eloy nice to see my post is in your hands. Now that I know this, I can add more information. The source server is the one of andreabix (MediaTouch). So, if you need to know the OS, the last update time, the Moodle release or whatever, ask him. The bug in the restore was with a db module. My original course is still on andreabix server. So go to see it if you need this. Also the backup is still on his server. I am always available for further information. Ciao.
          Hide
          Daniele Cordella added a comment -

          At the end of the process, I had no new roles in my local Mac server.
          I also was missing the two extra user enrolled in my course.

          Show
          Daniele Cordella added a comment - At the end of the process, I had no new roles in my local Mac server. I also was missing the two extra user enrolled in my course.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Notices are out now. They weren't causing any problem but better to avoid them. Thanks for the report. Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Notices are out now. They weren't causing any problem but better to avoid them. Thanks for the report. Ciao
          Hide
          Andrew Davis added a comment -

          Adding myself as QA Assignee.

          The code changes all look sensible enough. I tried to restore the backed up course in moodle 1.9.8 but got an error saying that restoring the user 'admin' would cause a conflict. The restore did not succeed. Eloy, is that a significant problem?

          Show
          Andrew Davis added a comment - Adding myself as QA Assignee. The code changes all look sensible enough. I tried to restore the backed up course in moodle 1.9.8 but got an error saying that restoring the user 'admin' would cause a conflict. The restore did not succeed. Eloy, is that a significant problem?

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: