Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11544

Blog tags are lost on upgrading from 1.8 to 1.9 beta

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9
    • Component/s: Blog
    • Labels:
      None
    • Environment:
      Linux/PostgreSQL
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Blog tags created in Moodle 1.8+ (2007021505) are not copied into the new tag and tag_instance tables when upgrading to 1.9 beta. It looks as though code is in place to do just this (lib/db/upgrade.php) and something is removing the old tables, but upgrade is not re-creating the old tags in the new tables on our platform of Linux/PostgreSQL. (Could table removal have occured before upgrade was called?)

        Attachments

          Activity

            People

            Assignee:
            lazyfish Yu Zhang
            Reporter:
            jb23347 John Beedell
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Sujith Haridasan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              3/Mar/08