Moodle
  1. Moodle
  2. MDL-1181

WebCT Quiz import: simple but showstopping bug with :IMAGE:

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: None
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      All
    • Database:
      Any
    • Affected Branches:
      MOODLE_12_STABLE
    • Rank:
      10139

      Description

      When the :IMAGE: field is blank, the importer complains that the image can't be found, and refuses to import the question.

      Simply needs to be changed so that if the content of the :IMAGE: field is , it understands that there's no image to be added.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Martin Dougiamas (martin at moodle.com) Thursday, 25 March 2004, 09:30 PM:

        Actually, looking at the code, this is not a showstopper at all ... it just prints a warning but still imports the question.

        The warning is probably sensible in that case.

        Perhaps there is another reason for what is happening there for you ...

        From Dan Stowell (d.stowell at ucl.ac.uk) Thursday, 25 March 2004, 09:56 PM:

        You're right. Thanks. To be honest, I disagree that the warning is probably sensible - if no image is specified then no teacher should be given a warning - file not found type message. (Don't want to put people off switching, eh, do you?!) But it's a v low priority to change that, as long as importing the questions works OK.

        From Martin Dougiamas (martin at moodle.com) Thursday, 25 March 2004, 10:03 PM:

        If WebCT is putting those empty IMAGE tags in by DEFAULT then yes, I agree, there shouldn't be the warning. I'll get rid of it for 1.2.1.

        Show
        Martin Dougiamas added a comment - From Martin Dougiamas (martin at moodle.com) Thursday, 25 March 2004, 09:30 PM: Actually, looking at the code, this is not a showstopper at all ... it just prints a warning but still imports the question. The warning is probably sensible in that case. Perhaps there is another reason for what is happening there for you ... From Dan Stowell (d.stowell at ucl.ac.uk) Thursday, 25 March 2004, 09:56 PM: You're right. Thanks. To be honest, I disagree that the warning is probably sensible - if no image is specified then no teacher should be given a warning - file not found type message. (Don't want to put people off switching, eh, do you?!) But it's a v low priority to change that, as long as importing the questions works OK. From Martin Dougiamas (martin at moodle.com) Thursday, 25 March 2004, 10:03 PM: If WebCT is putting those empty IMAGE tags in by DEFAULT then yes, I agree, there shouldn't be the warning. I'll get rid of it for 1.2.1.
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: