Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.9
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      Red Hat 9
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      Hi Urs,

      I the 1.9 Beta 2 I see that every block has ugly Skip links... f.x. 'Skip Adminstration Block'

      Normally it is symbolized with an Icon - but it stands with 3 wrapped text linked lines.

      Even in the new rounded corner theme made for 1.9,-

      How to resolve this??

      BR
      Jens

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              Hide
              jensmoodle Jens Gammelgaard added a comment -

              Strange - now it is gone - mabye cleaned out via the cron

              Show
              jensmoodle Jens Gammelgaard added a comment - Strange - now it is gone - mabye cleaned out via the cron
              Hide
              nfreear Nick Freear added a comment -

              Thanks for reporting this.
              Changes were made to the style sheets as part of fixes to the skip block links - see MDL-11695. The problem you experienced is to do with style sheet caching in Internet Explorer (you were using IE, right?) You can force a page refresh using Control+F5. See MDL-11676 for similar comments from Petr.

              There's no workaround I can think of - standard theme style sheets expire after 10 minutes anyway, so this should only affect developers looking right after a Moodle upgrade, not students.
              Nick

              Show
              nfreear Nick Freear added a comment - Thanks for reporting this. Changes were made to the style sheets as part of fixes to the skip block links - see MDL-11695 . The problem you experienced is to do with style sheet caching in Internet Explorer (you were using IE, right?) You can force a page refresh using Control+F5. See MDL-11676 for similar comments from Petr. There's no workaround I can think of - standard theme style sheets expire after 10 minutes anyway, so this should only affect developers looking right after a Moodle upgrade, not students. Nick
              Hide
              ray Ray Lawrence added a comment -

              Hi Nick,

              This issue is very much present in 1.8.3 + for IE6, FF, Safari even after many forced refreshes.

              Same for standard themes and custom themes.

              Server:
              PHP 4.4.7 MySQL 5.0.38

              Show
              ray Ray Lawrence added a comment - Hi Nick, This issue is very much present in 1.8.3 + for IE6, FF, Safari even after many forced refreshes. Same for standard themes and custom themes. Server: PHP 4.4.7 MySQL 5.0.38
              Hide
              nfreear Nick Freear added a comment -

              Hi Ray,
              I've switched to that branch and cannot reproduce in Win/Firefox or IE 6. Some ideas,

              • If you're updating from CVS, are you sure you're completely up-to-date on the 1.8 branch?
              • http://moodle.org is 1.9 Beta 2, but the code concerned is the same - does this site work for you? Try using the TAB key to move through links on the home page.
              • Can you attach copies of 2 files, lib/weblib.php and theme/standard/styles_layout.css to this bug?

              Thanks Nick.

              Show
              nfreear Nick Freear added a comment - Hi Ray, I've switched to that branch and cannot reproduce in Win/Firefox or IE 6. Some ideas, If you're updating from CVS, are you sure you're completely up-to-date on the 1.8 branch? http://moodle.org is 1.9 Beta 2, but the code concerned is the same - does this site work for you? Try using the TAB key to move through links on the home page. Can you attach copies of 2 files, lib/weblib.php and theme/standard/styles_layout.css to this bug? Thanks Nick.
              Hide
              ray Ray Lawrence added a comment - - edited

              Cheers Nick.

              I've also updated a couple of other site on a CVS updated server since the last report with no issues. The problem updates were based on a latest stable zip download and were tested with versions pre and post my CVS update. A roll back to 1.8+ fixed the issue. The site was switched between php 4 above and 5 (something) too with no effect.

              Please keep this open, I'll contact the client who is experiencing the problem to get a copy of the files above (or even better, Ronny, can you post them here?)

              Show
              ray Ray Lawrence added a comment - - edited Cheers Nick. I've also updated a couple of other site on a CVS updated server since the last report with no issues. The problem updates were based on a latest stable zip download and were tested with versions pre and post my CVS update. A roll back to 1.8+ fixed the issue. The site was switched between php 4 above and 5 (something) too with no effect. Please keep this open, I'll contact the client who is experiencing the problem to get a copy of the files above (or even better, Ronny, can you post them here?)
              Hide
              desteini Ronny Steinmetz added a comment -

              Hey there...

              The problem is still persistent in the latest *.zip-build from this morning (tried it locally on MAMP php 4.4.7 & mySQL5.4.1 -> same specs as the live server).

              See attached files "/lib/weblib.php" and the "/themes/standard/styles_layout.css" from this morning's update.

              Show
              desteini Ronny Steinmetz added a comment - Hey there... The problem is still persistent in the latest *.zip-build from this morning (tried it locally on MAMP php 4.4.7 & mySQL5.4.1 -> same specs as the live server). See attached files "/lib/weblib.php" and the "/themes/standard/styles_layout.css" from this morning's update.
              Hide
              nfreear Nick Freear added a comment -

              I'm afraid I disagree. I have again downloaded "Moodle 1.8.3+ / MOODLE_18_STABLE / Built Daily" (moodle-latest-18.zip) from http://download.moodle.org . This theme/standard/styles_layout.css is dated 13 October 2007 and contains the correct CSS:

              /*Accessibility: Skip block link, for keyboard-only users. */
              a.skip-block {
              position: absolute;
              top: -1000em;
              font-size: 0.85em;
              }
              a.skip-block:focus, a.skip-block:active {
              position: static;
              display: block;
              } ...

              The CSS file in the your attached Zip is dated 14 May 2007 and contains incorrect styles:

              /*Accessibility: Skip block link, for screen reader users. */
              a.skip-block, .skip-block {
              display:block;
              width:2em;
              height:1px;
              } ...

              Possible explanations:

              • You are mistakenly downloading an older Zip, for example "Moodle 1.8.3 / MOODLE_183 / 11th October 2007" (moodle-1.8.3.zip).
              • You have several Moodle source directories or are mis-copying to the server.

              So still "Cannot reproduce". Hope this helps. Nick

              Show
              nfreear Nick Freear added a comment - I'm afraid I disagree. I have again downloaded "Moodle 1.8.3+ / MOODLE_18_STABLE / Built Daily" (moodle-latest-18.zip) from http://download.moodle.org . This theme/standard/styles_layout.css is dated 13 October 2007 and contains the correct CSS: /*Accessibility: Skip block link, for keyboard-only users. */ a.skip-block { position: absolute; top: -1000em; font-size: 0.85em; } a.skip-block:focus, a.skip-block:active { position: static; display: block; } ... The CSS file in the your attached Zip is dated 14 May 2007 and contains incorrect styles: /*Accessibility: Skip block link, for screen reader users. */ a.skip-block, .skip-block { display:block; width:2em; height:1px; } ... Possible explanations: You are mistakenly downloading an older Zip, for example "Moodle 1.8.3 / MOODLE_183 / 11th October 2007" (moodle-1.8.3.zip). You have several Moodle source directories or are mis-copying to the server. So still "Cannot reproduce". Hope this helps. Nick
              Hide
              desteini Ronny Steinmetz added a comment -

              Ok Nick I found the problem...
              After updating to the new version I replaced the new themes folder with the backuped one, to maintain our customized themes, instead of including only our own theme.
              Works well now.
              Thanks a lot and sorry for the inconvenience.
              Ronny

              Show
              desteini Ronny Steinmetz added a comment - Ok Nick I found the problem... After updating to the new version I replaced the new themes folder with the backuped one, to maintain our customized themes, instead of including only our own theme. Works well now. Thanks a lot and sorry for the inconvenience. Ronny
              Hide
              ray Ray Lawrence added a comment -

              Aha! I didn't realise you'd moved all themes over.

              Thanks Nick for helping to track this one down.

              Ray

              Show
              ray Ray Lawrence added a comment - Aha! I didn't realise you'd moved all themes over. Thanks Nick for helping to track this one down. Ray

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: