Moodle
  1. Moodle
  2. MDL-12057

admin/mnet/index.php differnt hardcoded table width

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.3
    • Fix Version/s: 1.9.8
    • Component/s: MNet
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      On admin/mnet/index.php two different table width are set:

      _ top one no width
      _ bottom one 635.

      By the way, the mnet admin pages lack "normal" CSS hooks and look strange in advanced themes. Please check and optimize the mnet admin pages.

      Thank you very much.

        Gliffy Diagrams

        1. index.patch
          0.9 kB
          Andrew Davis
        2. styles-layout.patch
          0.5 kB
          Andrew Davis

          Activity

          Urs Hunkler added a comment -

          Screenshot showing the different block width :: http://screencast.com/t/yYHPVExwW1T

          Andrew Davis added a comment -

          The tables that were different widths are actually within those with hard coded widths. The problem was that the two subtables had no widths at all specified on them meaning they defaulted to however wide they needed to be. The top table has skinny content in it so it doesn't take up all of the available space.

          I added an entry to /these/standard/styles_layout.css that makes these subtables take up 100% of the space available to them within the outer table.

          .generalboxcontent table

          { width:100%; }
          Dakota Duff added a comment -

          This style affects table sizes on a number of other pages. Can the style please be modified to prevent this?

          Andrew Davis added a comment -

          It can if necessary. Is the change causing a problem? Can you attach a screenshot?

          Mauno Korpelainen added a comment -

          I can conform at least one new bug caused by this bug fix:

          it breaks (makes too wide) editor toolbar width on course pages.

          http://moodle.org/mod/forum/discuss.php?d=139526

          Mauno Korpelainen added a comment -

          Andrew,

          you should have more specific css than

          .generalboxcontent table

          Otherwise any tables inside generalbox content get 100% width if there is no other css that defines table width.

          Andrew Davis added a comment -

          reopening this issue.

          Andrew Davis added a comment -

          Patches attached to limit it to the mnet admin page. Further comments welcome

          Martin Dougiamas added a comment -

          Use a #admin-mnet-index selector Andrew

          Andrew Davis added a comment -

          Committed using the selector as per Martin's suggestion


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: