Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.8.4, 1.9, 2.0
    • Component/s: Roles / Access
    • Labels:
      None
    • Environment:
      Mysql (not sure) php 5.1.6
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      A mentor role has been set up from scratch.
      Capabilities set to allow are viewusergrades, viewcoursegrades, managegrades, viewreports, viewdetails, viewuseractivitiesreport, viewparticipants.
      An individual is assigned as a mentor in the the context of a user who is a student in courses where grades are recorded in the grade book.
      The mentees block is enabled on the front page. When the mentor accesses the user via the mentees block the "Grade" link does not show any grade information.

        Gliffy Diagrams

          Activity

          lazyfish Yu Zhang added a comment -

          Hi Ray,

          I tried your exact setting. You are seeing no grades because the block is placed on the site front page, and it is pointing to the front page course. What you need to do is to click on any course of the student (on their profile page), and then go to the grades, and you will be able to see their grades for this particular course.

          I also fixed an issue where parents will be forced to enrol in these courses. So you will need to update your code to get this to run smoothly.

          Cheers,

          Yu

          mina Nicolas Martignoni added a comment -

          Closing as this is not a bug, per Yu comment.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Jan/08