Moodle
  1. Moodle
  2. MDL-12234

Problems with Global Search (Zend Engine Search) with not english symbols

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9, 2.0
    • Component/s: Global search
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE
    • Rank:
      29894

      Description

      Problems with Global Search (Zend Engine Serch) with not english symbols

      1. Indexing but not search if query is not english text.
      2. If searching english text, in search results all not english words show in unicode.
      3. In Advanced Search after search all not english words in all fields change to unicode string.

      2,3 in attach

      1. 2.JPG
        117 kB
      2. 3.JPG
        112 kB

        Activity

        Hide
        Yu Zhang added a comment -

        Hi, should be fixed in cvs, please update. You might need to do indexing again.

        Cheers,

        Yu

        Show
        Yu Zhang added a comment - Hi, should be fixed in cvs, please update. You might need to do indexing again. Cheers, Yu
        Hide
        Mark Nielsen added a comment -

        Same problem exists in MOODLE_18_STABLE, see MDL-12577

        Show
        Mark Nielsen added a comment - Same problem exists in MOODLE_18_STABLE, see MDL-12577
        Hide
        Miroslav Fikar added a comment -

        The problem still exists in the latest Moodle 1.8.4+. Could the fixes be done in it?

        Show
        Miroslav Fikar added a comment - The problem still exists in the latest Moodle 1.8.4+. Could the fixes be done in it?

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: