Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-12291

help.php is not able to skip _local langpacks

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8, 1.8.1, 1.8.2, 1.8.3, 1.9
    • Fix Version/s: 1.8.4, 1.9
    • Component/s: Language
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      When a translator modify a master help file and there is a _local version of the file, the preview does not work. The reason is in help.php all _local version take precedence. We are not able to force help.php to skip these _local versions.

      The patch is trivial and is attached. It introduces new optional param $skiplocal, default 0 (do not skip).

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            koen Koen Roggemans added a comment -

            Sending this patch to Martin for review

            Show
            koen Koen Roggemans added a comment - Sending this patch to Martin for review
            Hide
            mudrd8mz David Mudrak added a comment -

            As I have got write access for help.php, I have committed the patch into HEAD, 1.9 and 1.8 branches.

            Show
            mudrd8mz David Mudrak added a comment - As I have got write access for help.php, I have committed the patch into HEAD, 1.9 and 1.8 branches.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jan/08