Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-12351

Forum does not show New discussion button when changed from visible groups to separate groups

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9
    • Component/s: Forum
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      I have a separate groups forum and have been told by a student that its 'not working properly'. I logged in as her, then saw that the forum gave the error 'Adding discussions to this forum requires group membership.' even though she is in the correct group and has added a discussion already.

      I realised that I had changed the course default groups mode from visible groups to separate groups and that this had changed the forum too. When I set it back to visible groups, the New discussion button reappeared.

        Attachments

          Activity

            People

            Assignee:
            skodak Petr Skoda
            Reporter:
            mattgibson Matt Gibson
            Tester:
            Dan Poltawski
            Participants:
            Component watchers:
            Andrew Nicols, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              3/Mar/08