Moodle
  1. Moodle
  2. MDL-12353

ewiki allow binary files "Edit" tab lead to a blank page when upload nothing

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.8, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.9
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Rank:
      3988

      Description

      OK I tested this across all major moodle versions, and it does exist in ALL major moodle releases. Here is how to reproduce:

      1. Create a wiki page, then click on th e"Update this wiki" button
      2. Make sure that you change the "Allow binary files" pull down menu from to "Yes" (for moodle 1.7 and 1.8 you might have to click on "Show Advanced" first). Click on "Save changes"
      3. Then click on the "Edit" tab, here you will see the "Browse" and "Upload" button (see screenshot)
      4. If you accidentally click on the "Upload" button without selecting any file, moodle will give you a blank page and you can't even go back to previous page - you are forced to close this window... very confusing for users

      There should be at least some kind of error / warning message and allow users to retry again...

      I could probably come up with a fix later and post it here.

        Issue Links

          Activity

          Hide
          Samuli Karevaara added a comment -

          In my tests this always happened to images over 64 Kb, but with smaller ones it worked.

          Show
          Samuli Karevaara added a comment - In my tests this always happened to images over 64 Kb, but with smaller ones it worked.
          Hide
          Michael de Raadt added a comment -

          Thanks for reporting this issue.

          We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported.

          If you believe that this issue is still relevant to current versions (2.3 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

          Michael d;

          4d6f6f646c6521

          Show
          Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.3 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d; 4d6f6f646c6521
          Hide
          Michael de Raadt added a comment -

          I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported.

          If you still believe this is an issue in supported versions, please report a new issue.

          Show
          Michael de Raadt added a comment - I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported. If you still believe this is an issue in supported versions, please report a new issue.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: