Resolution: Won't Fix
Affects Version/s: 1.9
Fix Version/s: None
Component/s: Database activity module
Something reported by our technical testing - they don't like the string: '1 more entries needed to view this database'.
The database string 'insufficiententries' is printed in a rather bad way:
notify (($data->requiredentriestoview - data_numentries($data)).' '.get_string('insufficiententries','data'));
The string itself is:
$string['insufficiententries'] = 'more entries needed to view this database';
This is bad for two reasons:
1) The string should have $a, for languages where it's more convenient to put the number elsewhere in the string.
2) In the most common case, the string says '1 more entries needed to view this database' - this is grammatically wrong, a bit unclear as to exactly what the user needs to do, and incorrect as to what they've done before (it says 'more' entries, but you haven't actually added any yet).
I propose creating two new language strings (I'm assuming that for legacy translation reasons, existing string should not be reused):
$string['insufficiententries_1']='You must add your own entry before you can view this database'
$string['insufficiententries_n']='You must add $a entries of your own before you can view this database'
I'm perfectly willing to do the change. Is this ok?