I propose adding the following method to the auth base class:
- Return the properly translated human-friendly title of this auth plugin
This places responsibility for working out the auth plugin's title within the auth plugin object, rather than having the code to do so in other places. This could also reduce code reuse. There would be little need for sub-classes to overload the method.
The attached patch adds the function, and replaces the code in admin/auth.php with a call to the new function.