Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-12515

Feedback not available to student on assignments unless a grade has been assigned WITH PATCH

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9, 2.0
    • Component/s: Assignment (2.2)
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      Feedback to students is not made available to students unless a grade has also been assigned. This is a bug caused by the $feedback variable not being set prior to being checked on line 244 (1.9 Beta3) of mod/assignment/lib.php.

      To fix, after $submission = $this->get_submission($USER->id); around line 233 of mod/assignment/lib.php, add the line $feedback = $submission->submissioncomment;

        Gliffy Diagrams

          Attachments

            Activity

            ganderson Gary Anderson added a comment -

            CVS type patch attached for this issue.

            poltawski Dan Poltawski added a comment -

            Confirmed this was the pre 1.9 behaviour.

            I think we should be using $grade->str_feedback instead in our empty check because this is what we display. Commiting that now.

            poltawski Dan Poltawski added a comment -

            I've fixed this in CVS, thanks for the report

            mgarrick Max Garrick added a comment -

            Patched against 1.9.1+. Allows viewing of feedback when no grade has been submitted. Shows teacher and dates.

            mgarrick Max Garrick added a comment -

            Can we please reopen this issue? We are able to reproduce the bug in 1.9.1+ build 20080528.

            etblomquist Ethan Blomquist added a comment -

            I would also like this issue reopened. I'm running Moodle 1.9.1+ (Build: 20080618), and am experiencing the same thing.

            etblomquist Ethan Blomquist added a comment -

            I would like to rescind my last comment. I was working from a relatively uninformed position, and since then, I have been trained. The feedback function on my site is working as expected.

            jboulen Julien Boulen added a comment -

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Mar/08