Moodle
  1. Moodle
  2. MDL-12564

not inherited standard stylesheet

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.3, 1.9
    • Fix Version/s: 1.8.4, 1.9
    • Component/s: Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Rank:
      29764

      Description

      I use the developer toolbar on firefox for macosX.
      I noticed, some weeks ago, I was missing the arrow in the navigation bar.
      To let you understand without misunderstandings, I am talking about this arrow:
      <button title="Previous activity" type="submit">
      <span class="arrow">?</span>
      <span class="accesshide"> Previous activity</span>
      </button>

      Well, by adding the right style to my theme
      .arrow, .arrow_button input {
      font-family: Arial,Helvetica,Courier,sans-serif;
      }
      all went right... but, why am I not inheriting this style from standard theme?
      So I went to my developer toolbar and I selected CSS->View CSS.
      What I got was a long page (http://myserver/moodle18/theme/standard/styles.php)
      starting with:
      http://myserver/moodle18/theme/standard/styles.php
      /**************************************

      • THEME NAME: standard
        *
      • Files included in this sheet:
        *
      • standard/styles_layout.css
      • /mod/assignment/styles.php
      • /mod/choice/styles.php
      • /mod/data/styles.php
      • /mod/lesson/styles.php
      • /mod/pagemenu/styles.php
      • /mod/quiz/styles.php
      • /mod/scorm/styles.php
      • /mod/workshop/styles.php
      • /blocks/blog_tags/styles.php
      • /blocks/calendar_month/styles.php
      • /blocks/calendar_upcoming/styles.php
      • /blocks/compliance/styles.php
      • /blocks/course_menu/styles.php
      • /blocks/course_summary/styles.php
      • /blocks/login/styles.php
      • /blocks/news_items/styles.php
      • /blocks/page_module/styles.php
      • /blocks/quiz_results/styles.php
      • /blocks/rss_client/styles.php
      • /blocks/search_forums/styles.php
      • /course/format/page/styles.php
        **************************************/

      Question and, maybe, bug: Why are not seen the other two standard stylesheet:
      styles_fonts.css and styles_color.css?

        Activity

        Urs Hunkler added a comment -

        Daniele, I can't reproduce the issue. When you still get it, please reopen with more detailed descriptions: which theme you use etc.

        Daniele Cordella added a comment -

        Ciao Urs.
        Whenever I use "Formal white" theme I am always missing the two arrow of the "Activity navigation".
        If you look at the style sheets of the theme you see that no style related to .arrow, .arrow_button input was added.

        So... why do the arrows are not visible?
        Is this a problem of missing inheriting?

        Don't hesitate to ask for any furher question.
        Ciao

        Urs Hunkler added a comment - - edited

        Reopened issue. Formal_white and Chameleon show this error. Thanks for clarifying Daniele.

        The arrows are not visible because those two themes only include styles_layout and not styles_fonts.

        Urs Hunkler added a comment -

        Andrea, I have corrected the issue for Chameleon. Please add the CSS to your theme too.

        Daniele Cordella added a comment - - edited

        Ciao Urs
        I went to see what changed with your intervention and I found that you added

        36 span.arrow

        { 37 font-family: Arial, Helvetica, Courier, sans-serif; 38 }

        39 p.arrow_button input

        { 40 font-family: Arial, Helvetica, Courier, sans-serif; 41 }

        to the file theme/chameleon/user_styles.css

        May I ask the reason why this addition is needed?
        AFAIK these styles should be inherited from the standard theme.
        Is this not correct?
        Formally you should include the third css file. Am I correct?

        Thank you in advance.
        Ciao

        Urs Hunkler added a comment -

        Daniele, if I would have decided to include all CSS files for layout, color and fonts the style would have been inherited.

        If I would have included all CSS, I would have needed to overwrite all styles from standard to get the look I want.

        When I only take the CSS for layout I can be sure that the theme won't break with the next update. And I have the advantage that I do not need all colors and fonts from standard but can define only the CSS I need. I avoid several KB CSS code.

        I need to take care not to forget any important definition. Missing CSS comes up some times.

        Daniele Cordella added a comment -

        Thanks Urs.
        I do always learn something!!
        Ciao

        Andrea Bicciolo added a comment -

        Fixed for formal_white theme in 1.8, 1.9 and HEAD. Closing issue.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: