Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-12572

Quiz downloaded reports contain html markup

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.3
    • Fix Version/s: 2.0
    • Component/s: Quiz
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      To reproduce (in 1.8.3 and 1.9, probably earlier versions as well):

      Create a quiz with essay questions.
      Log in as a student, take the quiz, apply some formatting to the essay answer in the html editor, and submit.
      As a teacher, go to the Item Analysis tab and download the report (any format).

      The student response in the downloaded report will contain html markup. Some of the column headers also contain <br /> tags, and question names and text can contain markup as well. This makes the downloaded reports difficult for faculty to analyze.

      When downloading reports, the html should first be converted to text. A patch is attached (1.9).

      Note that the same issue exists with the Detailed Responses plugin. I'll file a separate report for that one.

        Gliffy Diagrams

        1. example_output_excel.xls
          120 kB
          Pierre Pichet
        2. example_output.doc
          699 kB
          Pierre Pichet
        3. quizreport.patch
          2 kB
          Ann Adamcik

          Issue Links

            Activity

            timhunt Tim Hunt added a comment -

            I'm just wondering if there are any situations where the person downloading the results would want the full HTML?

            ppichet Pierre Pichet added a comment -

            I agree with Tim.
            This is why we use HTML editor to answer in some questions types.
            There can be also necessary formatting in the question text .
            For example using superscript and underscript in chemical formulas.

            Perhaps we should create an HTML output.
            In the mean time, select the table data on your browser, copy and paste as HTML in Word and everything becomes readable
            see the attachement

            ppichet Pierre Pichet added a comment -

            copy and paste example.
            This does not fullfill all needs but can be usefull.

            ppichet Pierre Pichet added a comment -

            The same copy and paste in excel.
            Here you can manipulate the columns.

            We should provide an HTML (XML?) ouput of the table.
            I am already working on Item analysis modifications so I can add this to my to-do list.

            ppichet Pierre Pichet added a comment -

            An HTML version has been build and CVS to HEAD

            see http://moodle.org/mod/forum/discuss.php?d=92376

            ppichet Pierre Pichet added a comment -

            Essay does not display the manual grading for each responses although it is OK in the other statistics.
            Add to my to-do-list

            ppichet Pierre Pichet added a comment -

            I am revising the different format ODS, XLS and CSV so that they can be more useful to do further analysis.
            These modifications will be merged down to older versions including 1.9 as they do not use new datatables.
            They could also be useful at least in part in the OU project.
            The HTML version allows to have a printed complete table that can also be managed in a word processing software.
            The Excel, ODS ans CSV versions will have more detailed columns so that their main purpose is to do further calculation or data sorting.
            The versions will be progressively put on HEAD to allow better testing before merged to 1.9 and older versions.

            ppichet Pierre Pichet added a comment -

            Added storage to database attempts in the $SESSION so there is no new search when sorting the table or downloading.

            A preview of the OU project to store results in the database.

            ppichet Pierre Pichet added a comment -

            Some settings combination for the refresh don't work correctly .
            I will test a

            jamiesensei Jamie Pratt added a comment -

            This is fixed in 2.0 since a new 'Statistics report' has replaced the item analysis report. Responses from essays are no longer displayed in response analysis table.

            jamiesensei Jamie Pratt added a comment -

            This is not fixed in 1.8 or 1.9. Assigning it to Tim, to consider.

            timhunt Tim Hunt added a comment -

            I think that since this is a minor problem, and because it was fixed by complete rewrite in Moodle 2.0, so there is no easy way to back-port the fix to 1.9, etc, it is not worth spending time fixing this independently in older versions. Therefore, I am resolving this bug as fixed in 2.0 only.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10