Moodle
  1. Moodle
  2. MDL-12972

Gradebook: Previous link to view individual student grades from "Grader Report" gone in 1.9

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9.7
    • Component/s: Gradebook
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      30729

      Description

      From the grader report there seems to be a change in behavior.

      In Moodle 1.8, when viewing the grades (/grade/index.php), clicking on the link of the user's name linked to:
      /grade/index.php?id=16&action=view_student_grades&user=826 (a grade report for the individual student)

      In Moodle 1.9, when viewing the grades via the grade report (/grade/report/grader/index.php?id=1819), clicking on the link of the user's name links to:
      /user/view.php?id=520&course=1819 (the user's profile)

      Previously links for both the user's name and the picture were available. The link for the user's pic would link to the user's profile. The link for the user's name would link to the grade report for the individual student. This seems to be a change in behavior.

      What I would expect to see is that the user's name link take us to the grades for the individual student (perhaps that user's gradebook "Users report"). I'm not sure of the best way to handle this with the new gradebook UI; however, I want to try to preserve the behavior. I found it very convenient to pull up the gradebook and be able to link to the individual grades of a particular student especially during parent teacher conferences as it prevented me from showing the parents information about other students.

      Peace - Anthony

      1. grader_index.html
        79 kB
        Anthony Borrow
      2. MDL-12972.patch
        7 kB
        Nicolas Connault
      1. chrome.png
        119 kB
      2. firefox35.png
        88 kB
      3. firefox35big.png
        138 kB
      4. ie6.png
        267 kB
      5. ie7.png
        266 kB
      6. mdl12972.png
        124 kB
      7. MDL-12972.png
        31 kB
      8. standardtheme.png
        144 kB

        Activity

        Anthony Borrow created issue -
        Anthony Borrow made changes -
        Field Original Value New Value
        Summary Gradebook: Previous link to view individual student grades gone in 1.9 Gradebook: Previous link to view individual student grades from "Grader Report" gone in 1.9
        Anthony Borrow added a comment -

        Eloy suggested assigning this to you while Yu is out. IMHO, it is not urgent but something I happened across while working on a possible set of patches for MDL-3942. Peace - Anthony

        Anthony Borrow made changes -
        Assignee Yu Zhang [ lazyfish ] Martin Dougiamas [ dougiamas ]
        Nicolas Connault made changes -
        Assignee Martin Dougiamas [ dougiamas ] Nicolas Connault [ nicolasconnault ]
        Nicolas Connault added a comment -

        This seems sensible, I suggest we address this in 1.9.6

        Nicolas Connault made changes -
        Fix Version/s 1.9.6 [ 10340 ]
        Camilo Rivera added a comment -

        Any Ideas where in the code to address this issue?? , I would like to get started on this.

        Anthony Borrow added a comment -

        I confess to having mixed feelings about this. On the one hand, I like the idea of being consistent with previous versions; however, from a usability standpoint when in other places of Moodle we see the user name as a link it takes us to the user profile. How can we be consistent. Might it be better to have another way of indicating that we just want to see a particular row? I'm not sure from a UI perspective what might be best but figured I would throw the idea out there. Peace - Anthony

        Sharon Goodson added a comment -

        This is far out of my area, but could a direct link to course/user grade mode be specified only in the grader/index page?

        Nicolas Connault added a comment -

        Attached is a patch that adds a "User grades" icon next to the user name. The screenshot shows the result.

        Nicolas Connault made changes -
        Attachment MDL-12972.patch [ 18517 ]
        Attachment MDL-12972.png [ 18518 ]
        Anthony Borrow added a comment -

        Nicolas - Here is what I noticed when I applied. Not sure the cause but figured I would report it:

        Incorrect scale id: 2

        • line 798 of lib/grade/grade_item.php: call to debugging()
        • line 705 of lib/gradelib.php: call to grade_item->load_scale()
        • line 667 of lib/gradelib.php: call to grade_format_gradevalue_real()
        • line 1948 of lib/grade/grade_item.php: call to grade_format_gradevalue()
        • line 329 of grade/report/user/lib.php: call to grade_item->get_formatted_range()
        • line 354 of grade/report/user/lib.php: call to grade_report_user->fill_table_recursive()
        • line 183 of grade/report/user/lib.php: call to grade_report_user->fill_table_recursive()
        • line 127 of grade/report/user/index.php: call to grade_report_user->fill_table()

        Incorrect scale id: 2

        • line 798 of lib/grade/grade_item.php: call to debugging()
        • line 705 of lib/gradelib.php: call to grade_item->load_scale()
        • line 667 of lib/gradelib.php: call to grade_format_gradevalue_real()
        • line 1949 of lib/grade/grade_item.php: call to grade_format_gradevalue()
        • line 329 of grade/report/user/lib.php: call to grade_item->get_formatted_range()
        • line 354 of grade/report/user/lib.php: call to grade_report_user->fill_table_recursive()
        • line 183 of grade/report/user/lib.php: call to grade_report_user->fill_table_recursive()
        • line 127 of grade/report/user/index.php: call to grade_report_user->fill_table()

        Peace - Anthony

        Anthony Borrow added a comment -

        Nicolas - I think you can safely ignore the above - I reversed the patch and seeing the same behavior before the patch so it is likely from some testing or other error already in the database. Patch looks OK but I found the image to be a bit crowded but I suspect this could be fixed with a little CSS magic. I'll attach a screen shot. Peace - Anthony

        Anthony Borrow added a comment -

        I think the image for the new link crowds the name a bit too much. Peace - Anthony

        Anthony Borrow made changes -
        Attachment mdl12972.png [ 18546 ]
        Nicolas Connault added a comment -

        Anthony, I'm not sure how you obtained that screenshot, because the new icon is actually in a separate cell from the student name... Can you post a dump of the output HTML for one of these cells please?

        Thanks

        Nicolas Connault added a comment -

        Looks like your student cells are a fixed width, and their text content overflows into the next cell... What theme do you use?

        Anthony Borrow added a comment -

        Nicolas - I was using the formal_white theme and am attaching the html of the file as requested. It looks like something happens when there are numerous columns that extend beyond a single page - some type of reducing the width of the name column to a minimum setting. When everything is visible on one screen width wise it looks great. I am also attaching a screenshot using the standard theme which shows similar behavior. Let me know if you have any questions. I did not see anything in the css that seemed to be calling attention to itself. I'll poke around the html file and see if I can find something note worthy. Peace - Anthony

        Anthony Borrow made changes -
        Attachment grader_index.html [ 18547 ]
        Attachment standardtheme.png [ 18548 ]
        Nicolas Connault made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Nicolas Connault added a comment -

        Anthony this is only happening when you use the "screenreader" version of this report (without the fixed students column). The main reason is explained in MDL-20418 and is separate from this issue.

        Anthony Borrow added a comment -

        FYI - I am looking at it using FF 3.0.14 running under Ubuntu. It appears to be something peculiar to FF. I tried it under a Virtual WinXP with FF 3.5 and saw the same behavior but Chrome looked fine. IMO it is really minor and cosmetic. I would not see this as a show stopper but it is strange. Peace - Anthony

        Anthony Borrow added a comment -

        Here are screen shots from Chrome on WinXP virtual box, FF 3.5 on WinXP with small text and larger text.

        Anthony Borrow made changes -
        Attachment chrome.png [ 18549 ]
        Attachment firefox35.png [ 18550 ]
        Attachment firefox35big.png [ 18551 ]
        Anthony Borrow added a comment -

        Thanks Nicolas - as long as it is a separate issue. The work on this looks good to me. I play with little things like this while I am in class between taking notes. Peace - Anthony

        Anthony Borrow added a comment -

        p.s. fyi - I did not have screenreader on but it does behave much nicer with static width of the student column.

        Martin Dougiamas made changes -
        Fix Version/s 1.9.7 [ 10360 ]
        Fix Version/s 1.9.6 [ 10340 ]
        Nicolas Connault made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Rossiani Wijaya added a comment -

        I tested the patch with ie6 and 7 on windows 7 and took screenshots for both of them.

        Rossiani Wijaya made changes -
        Attachment ie6.png [ 18738 ]
        Attachment ie7.png [ 18739 ]
        Tim Hunt added a comment -

        Note, the patch committed here was buggy. See MDL-21159.

        Andrew Davis added a comment -

        Closing. Any remaining display problems can be dealt with in separate issues

        Andrew Davis made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        QA Assignee andyjdavis
        Martin Dougiamas made changes -
        Workflow jira [ 24319 ] MDL Workflow [ 58476 ]
        Martin Dougiamas made changes -
        Workflow MDL Workflow [ 58476 ] MDL Full Workflow [ 87617 ]

          People

          • Votes:
            7 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: