Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-13276

Fatal error in files/index.php

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8.5
    • Component/s: Libraries
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      Here is the error:

      Fatal error: Call to a member function get_id() on a non-object in /path/to/lib/blocklib.php on line 920

      Here is the traceback:

      • line 919 of lib/blocklib.php: call to debugging()
      • line 453 of lib/blocklib.php: call to blocks_get_by_page()
      • line 2710 of lib/adminlib.php: call to blocks_setup()
      • line 47 of files/index.php: call to admin_externalpage_print_footer()
      • line 616 of files/index.php: call to html_footer()

      To reproduce:

      1. On the site home page, add a resource that links to a file or web page.
      2. Click on the Choose or upload a file... button
      3. Error is displayed at the bottom.

      I haven't tested to see if this is still a problem in 1.9 or later, but the code is different post 1.8 due to MDL-9647

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda added a comment -

            fixed in cvs, thanks for the report

            mina Nicolas Martignoni added a comment -

            Closing, verified on MOODLE_18_STABLE from CVS.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Apr/08