Moodle
  1. Moodle
  2. MDL-13847 backup/restore issues meta
  3. MDL-13425

Backup / restore and course import bring over calendar events

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.11, 1.8.12, 1.9.7, 1.9.8, 2.0
    • Fix Version/s: 2.3
    • Component/s: Backup
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE

      Description

      Manually added calendar events are always imported, and there is no check box to de-select events. Users must manually delete any extraneous calendar entries after importing.

      To reproduce:

      In course A -
      Make sure the course contains a resource or activity
      Add a calendar event

      In course B -
      Select Import
      Choose course A
      Select any resource or activity to import

      The expected result is that only the checked resource or activity should be imported.
      The actual result is that the calendar event from course A also gets imported to course B.

        Gliffy Diagrams

          Activity

          Michael Spall added a comment -

          I am raising the priority on this because it really reduces the users ability to use import or back/up and restore because of the potential unintended consequences of bringing in a large number of manual calendar events. Even a partial fix of having a drop down list that would allow selecting importing all or none of the manual calendar events would be good. This would be similar to how course files are currently treated in backup and restore. Ideally you would be able to pick events similar to picking quizzes, etc.

          Rod Spears added a comment -

          What is the status on this issue? It has been almost a year since this was updated.

          This is still happening in 1.9.5. I can no longer show the calendar to students in the course because there are so many events with incorrect dates.

          Rod Spears added a comment -

          It also happens during a restore from backup.

          Rod Spears added a comment -

          A short time after I posted the previous comments I found a work around for this. I used the reset option to delete all the events from the calendar.
          http://docs.moodle.org/en/Reset_course

          Michael Spall added a comment -

          Rod's idea is a good work around for courses that don't already have manual calendar events. But if you have some manual calendar events that you want to keep, then reset removes all of them.

          Helen Foster added a comment -

          Ann, thanks for reporting this issue, and thanks everyone for your comments and votes.

          I've just added backup expert Eloy as a watcher to request that he looks at this issue

          Kym Lawry added a comment -

          I have the same issue in our moodle - 1.9.3

          It has created severe problems for a number of staff - after my effort in convincing them that the Calendar is a great organisational tool in moodle - it is - for many - now populated with "bogus" events.

          It is now 18 months since this issue was raised. It would seem to me to well worth fixing.....

          The "reset" workaround is not a solution in our context.

          sal added a comment -

          In August I upgraded site from 1.9.7 to 1.9.9 and this problem is still occuring for me. So might be time to update the affected versions to include 1.9.9!

          Helen Foster added a comment -

          Sorry to hear that this problem still occurs in 1.9.9.

          Can anyone check (perhaps on our Moodle QA Testing site http://qa.moodle.net/) whether the problem occurs in Moodle 2.0 RC1?

          Andrew Tate added a comment -

          Hi there,

          I just tried on our 2.0 dev site and after restoring to a new course, the events tied to the old course were NOT duplicated--the calendar in the new course was completely clean of events.

          Site-level events do display after backup&restore/throughout all courses, which should be the desired result.

          Ankit Agarwal added a comment -

          This issue should be fixed now (After MDL-22895 and MDL-32431 are integrated!)

          Now you can select if you want to export/import calendar events.

          IMHO it is safe to close this issue.
          Thanks

          Helen Foster added a comment -

          Thanks Ankit, closing as suggested.

          Thanks also for everyone's comments and votes.


            People

            • Votes:
              26 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: