Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9
    • Component/s: Administration
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      problem is that the stats UI expects the exact day end timestapts in db which is wrong, because site may change timezone, dst, ect.
      solution: add date normalization into stats_fix_zeros()

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mspall Michael Spall added a comment -

              Is this the underlying reason for the DST issue in MDL-12031?

              skodak Petr Skoda added a comment -

              stats uses a bit different logic than logs, though the problem is similar; it is a bit hacky at present, I hope it will solved finally when we switch to native PHP 5.2.x date functions in Moodle 2.0

              skodak Petr Skoda added a comment -

              done


                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    3/Mar/08