Moodle
  1. Moodle
  2. MDL-13481

Distinguish between course "fullname" and user "fullname"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 2.0.3
    • Component/s: Language
    • Labels:
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      600

      Description

      At the moment, the get_string('fullname', 'moodle') is used for both course fullname (e.g. in course/edit_form.php) and for user fullname (e.g. admin/user/usert_bulk.php). This causes problems in languages where different words should be used for names of persons and for names of things.

      There is a proposal to introduce new strings "coursefullname", "courseshortname" instead of current "fullname" and "shortname" and keep "fullname" (or even better new "userfullname") for user full name only.

        Issue Links

          Activity

          Hide
          Koen Roggemans added a comment -

          m.i. It should be two new strings for backward compatability

          Show
          Koen Roggemans added a comment - m.i. It should be two new strings for backward compatability
          Hide
          Martin Dougiamas added a comment -

          Dongsheng, we need to add two strings coursefullname and userfullname in lang/en_utf8/moodle.php and carefully fix all the places where get_string('fullname') was used so that it's either get_string('coursefullname') or get_string('userfullname') as appropriate. Just in HEAD, thanks.

          Show
          Martin Dougiamas added a comment - Dongsheng, we need to add two strings coursefullname and userfullname in lang/en_utf8/moodle.php and carefully fix all the places where get_string('fullname') was used so that it's either get_string('coursefullname') or get_string('userfullname') as appropriate. Just in HEAD, thanks.
          Hide
          Martin Dougiamas added a comment -

          Actually fullnameuser and fullnamecourse would be better names (puts them next to each other for translators).

          Show
          Martin Dougiamas added a comment - Actually fullnameuser and fullnamecourse would be better names (puts them next to each other for translators).
          Hide
          David Mudrak added a comment -

          Please, is there any chance to backport this into MOODLE_19_STABLE? It is very difficult to find an translation of "fullname" in both user and course context. If this fix is intended for 2.0 only, I will have to live with messy language pack for the whole long 1.9 live cycle Moreover, I would have to change the Moodle terminology now and then again in 2.0

          Show
          David Mudrak added a comment - Please, is there any chance to backport this into MOODLE_19_STABLE? It is very difficult to find an translation of "fullname" in both user and course context. If this fix is intended for 2.0 only, I will have to live with messy language pack for the whole long 1.9 live cycle Moreover, I would have to change the Moodle terminology now and then again in 2.0
          Hide
          David Mudrak added a comment -

          See my last comment for the reopening reason. Feel free to assign this to myself if you agree with backporting this. TIA

          Show
          David Mudrak added a comment - See my last comment for the reopening reason. Feel free to assign this to myself if you agree with backporting this. TIA
          Hide
          Dongsheng Cai added a comment -

          Hi, David, it is yours, thanks

          Show
          Dongsheng Cai added a comment - Hi, David, it is yours, thanks
          Hide
          David Mudrak added a comment -

          Both strings fullnamecourse and fullnameuser were created in the English pack. Now testing if AMOS CPY command will work with the initial splitting.

          Show
          David Mudrak added a comment - Both strings fullnamecourse and fullnameuser were created in the English pack. Now testing if AMOS CPY command will work with the initial splitting.
          Hide
          David Mudrak added a comment -

          Final cleanup commit submitted for Moodle 2.0. This will not be backported to 1.9.

          Show
          David Mudrak added a comment - Final cleanup commit submitted for Moodle 2.0. This will not be backported to 1.9.
          Hide
          Helen Foster added a comment -

          As mentioned by Eloy, MDL-20562 is similar to this issue. Hoping David can come to the rescue again!

          Show
          Helen Foster added a comment - As mentioned by Eloy, MDL-20562 is similar to this issue. Hoping David can come to the rescue again!
          Hide
          Helen Foster added a comment -

          David, thanks for fixing this issue.

          Show
          Helen Foster added a comment - David, thanks for fixing this issue.

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: