Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-13538

new effective permissions tab in user section

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Roles / Access
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      the idea is to allow teachers or administartors to view the list of capabilities each user has in given course context or module context.

      implementation is pretty simple -either new first row tab or a subtab of Role tab.

      sending unfinished patch with preview

        Gliffy Diagrams

        1. 0001-admin-roleaudit-New-unsupported-admin-page-to-displ.patch
          6 kB
          Francois Marier
        2. premissions_tab_4.patch
          15 kB
          Petr Skoda
        3. premissions_tab_7.patch
          19 kB
          Petr Skoda
        4. premissions_tab_8.patch
          17 kB
          Petr Skoda
        1. permissions.png
          47 kB

          Issue Links

            Activity

            francois Francois Marier added a comment -

            (This patch is only vaguely related to this, but I figure I should put it somewhere in case there is interest.)

            We whipped out a quick "audit" page for one of our customers who wanted to see all role assignments on the site. If you think that this functionality should be added to the unsupported pages, then I can work on it some more....

            jisner John Isner added a comment -

            Possible duplicate of MDL -13228. "Improve the transparency of Roles and Capabilities by adding a View permissions tab"

            timhunt Tim Hunt added a comment -

            As per John's comment.

            mina Nicolas Martignoni added a comment -

            Closing as dupe.

            skodak Petr Skoda added a comment - - edited

            reopening - the ideas in linked bug are different from mine

            skodak Petr Skoda added a comment -

            sending a fresh patch with permissions tab on user page, please test

            skodak Petr Skoda added a comment -

            some more improvements

            skodak Petr Skoda added a comment -

            I hope it is production quality now

            skodak Petr Skoda added a comment -

            here is a screenshot

            howardsmiller Howard Miller added a comment -

            I think there's some crossover here. To integrate Tim's report as a report (if you see what mean) doesn't make much sense. It works better as an option from the user's profile. My intention was never to show the full list of capabilities, just the role, but it's nearly the same thing.

            skodak Petr Skoda added a comment -

            closing, looks like nobody needs this

            tsala Helen Foster added a comment -

            Reopening, following a request in the roles and capabilities forum.

            timhunt Tim Hunt added a comment -

            This is on my todo list for Moodle 2.0.

            timhunt Tim Hunt added a comment -

            Done!


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10