Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-13609

Reverse order of grouping settings in activity/resource/label settings page (easy, with solution)

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.9.1
    • Fix Version/s: None
    • Component/s: Administration, Course, Groups
    • Labels:
      None
    • Environment:
      any
    • Database:
      Any
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      The typical decision process for making a grouping allocation is:

      Should this be available for group members only?
      If "Yes", enable that option.
      Select grouping.

      The settings for groupings are the opposite way around which is most unintuitive i.e.

      Grouping
      Available for group members only

      Suggestion: Reverse the order.

        Gliffy Diagrams

          Issue Links

            Activity

            ray Ray Lawrence created issue -
            ray Ray Lawrence added a comment -

            Update:

            The above is the position with resources. The set up for activity modules is different i.e. the order of the settings is as outlined above but the Grouping drop-down is enabled.

            So, updating my suggestion above:
            Change activities to reverse the order or;
            Enable the Grouping drop-down by default for Resources.

            fox Séverin Terrier added a comment -

            Yes, the way it's done now is unlogical.

            Just have to inverse code for the checkbox, before the grouping selection

            Solution : in "course/moodleform_mod.php" modify function "standard_coursemodule_elements"

            Moving these lines just before the other if in the same function (just under the line "if (!empty($CFG->enablegroupings)) {") :

            if ($this->_features->groupmembersonly)

            { $mform->addElement('checkbox', 'groupmembersonly', get_string('groupmembersonly', 'group')); $mform->setAdvanced('groupmembersonly'); }
            fox Séverin Terrier made changes -
            Field Original Value New Value
            Summary Reverse order of grouping settngs in activty/resource/label settings page Reverse order of grouping settings in activity/resource/label settings page (easy, with solution)
            Fix Version/s 1.9.2 [ 10280 ]
            Affects Version/s 1.9.1 [ 10240 ]
            Affects Version/s 1.9 [ 10190 ]
            fox Séverin Terrier made changes -
            Link This issue has a non-specific relationship to MDL-14975 [ MDL-14975 ]
            fox Séverin Terrier added a comment -

            Hopefully, Petr will find 2 minutes to close this simple bug

            fox Séverin Terrier made changes -
            Assignee Martin Dougiamas [ dougiamas ] Petr Skoda [ skodak ]
            skodak Petr Skoda added a comment - - edited

            hmm, sometimes things are not as easy as they might seem

            The Grouping option is shared by both "Available for group members only" and "Group mode" - you propose to move it away from the "Group mode" which might be considered more "unintuitive".
            Seems that any order of these three options has its pluses and minuses - I am not really sure everybody will agree on the same best order, my personal favourite is the current one.

            Problem here is that there is a possibility that if we change this in middle of stable branch some other ppl will complain and will want to revert this change.

            Are you 100% sure now that this change will please everybody?

            tsala Helen Foster added a comment - - edited

            Petr, thanks for your comment.

            Just thinking that if the order is changed to:

            Group mode
            Available for group members only
            Grouping

            then people may select "Available for group members only" and not realise they need to select a grouping too.

            Perhaps we could leave the order as it is and change the wording slightly to "Available for grouping members only"?

            Edited to add: Just noticed the linked issue MDL-14975

            tsala Helen Foster made changes -
            Link This issue has been marked as being related by MDL-14972 [ MDL-14972 ]
            skodak Petr Skoda added a comment -

            nope, the group member is correct - it works also without groupings; you just need to be member if any course group if grouping not selected

            ray Ray Lawrence added a comment -

            OK, now I'm confused.

            Petr, are you saying that an activity can be made visible to members of a group only?

            How does one select which group(s) in the single check box?

            Shouldn't it be the case that the check box should only be visible if there is at least one grouping for the course? And if so the label would be better altered to "Available for grouping members only".

            Regarding the change in a stable branch. It's not so important to warrant that level of disruption but is sufficiently awkward to justify modifying for 1.9.2.

            skodak Petr Skoda added a comment -

            No, not one group - you need to be member of any group in course or any group in grouping - depending on Groupings option

            skodak Petr Skoda added a comment -

            I do not think it should be disabled, because you might add groups/groupings later

            ray Ray Lawrence added a comment -

            I'm still confused.

            1. If the check box is ticked and there are groups anyone who is a member of a group will see the activity/resource?
            2. The check box has nothing to do with groupings?

            skodak Petr Skoda added a comment - - edited

            the group members only is related to groups available in activity and hence indirectly to grouping used in activity if selected

            grouping restricts the number of groups available in activity

            skodak Petr Skoda added a comment -

            it is really not clear which option is better, in that case let's not change it in stable branch

            skodak Petr Skoda made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Fix Version/s 1.9.2 [ 10280 ]
            Resolution Not a bug [ 7 ]
            dougiamas Martin Dougiamas made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            QA Assignee nobody
            dougiamas Martin Dougiamas made changes -
            Workflow jira [ 25056 ] MDL Workflow [ 58930 ]
            dougiamas Martin Dougiamas made changes -
            Workflow MDL Workflow [ 58930 ] MDL Full Workflow [ 88076 ]

              People

              • Votes:
                4 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: