Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-13742

Course creator can't create subcategories, when assigned in category context

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9.4
    • Component/s: Roles / Access
    • Labels:
      None
    • Environment:
      Linux debian etch
      mysql 5.0.32
      php 5.2.0.8.10
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      In Moodle 1.9 Beta 4 + (2007101508.08) when I assign the course creator role in category context it is impossible to create a subcategory.

      This worked before in 1.8.4.

      Details:

      The capability of creating categories is granted to the role of course creator on site context. (default settings)
      After assigning the role it is possible to join the editing mode in a category, and the button for creating a subcategory is shown.
      Clicking this button will display a form, requesting the information for the new subcategory.

      But now, a click on the submit/save button won't show the expected page, saying "change saved", but the editing form again.

      It's unclear if the feature, giving a course creator the capability to create subcategories on category context and below, was taken away since 1.8.4 or this is a bug. Anyway it is a feature which should be available. Otherwise you only can create a course creator as a global role, making not much sense due to the fact that such an assignment works for the whole site. Many want restrict the permission of creating categories on a defined region like a category context and beneath.

      Jörg

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              jknegten Jörg Knegten created issue -
              jknegten Jörg Knegten made changes -
              Field Original Value New Value
              Priority Critical [ 2 ] Major [ 3 ]
              skodak Petr Skoda added a comment -

              assigning to NIcolas, please have a look at this

              skodak Petr Skoda made changes -
              Fix Version/s 1.9.1 [ 10240 ]
              Assignee Martin Dougiamas [ dougiamas ] Nicolas Connault [ nicolasconnault ]
              nicolasconnault Nicolas Connault added a comment -

              I think you're mistaken. The course creator role in 1.8 and above does NOT have the capability to create categories by default. Of course, you can give it to him in order to achieve the desired result.

              nicolasconnault Nicolas Connault made changes -
              Status Open [ 1 ] Closed [ 6 ]
              Resolution Not a bug [ 7 ]
              jknegten Jörg Knegten made changes -
              Attachment creator_override.pdf [ 13341 ]
              jknegten Jörg Knegten added a comment -

              Hello Nicolas,

              thank you for your reply.

              Surely I know, that the permission to create a category is not given by default.

              So I gave this persmisson to the course creator on site level before trying to create a subcategory.

              I documentet my steps with some screenshots in a pdf, which was uploaded now as an attachment.

              Please take an additional look at this.

              Jörg

              jknegten Jörg Knegten made changes -
              Link This issue is a clone of MDL-11936 [ MDL-11936 ]
              tsala Helen Foster added a comment -

              Reopening, as this does indeed appear to be a bug.

              Jörg, thanks for your comments and pdf.

              tsala Helen Foster made changes -
              Resolution Not a bug [ 7 ]
              Status Closed [ 6 ] Reopened [ 4 ]
              Fix Version/s 1.9.1 [ 10240 ]
              jknegten Jörg Knegten added a comment -

              Hi Helen,
              thanks for taking an effort on this again.
              Enjoy the lovely evening
              Jörg

              timhunt Tim Hunt added a comment -

              Grabbing a bunch of related course category editing bugs that I plan to work on. Sorry for all the emails.

              timhunt Tim Hunt made changes -
              Fix Version/s 1.9.3 [ 10290 ]
              Assignee Nicolas Connault [ nicolasconnault ] Tim Hunt [ timhunt ]
              dougiamas Martin Dougiamas made changes -
              Fix Version/s 1.9.4 [ 10300 ]
              Fix Version/s 1.9.3 [ 10290 ]
              timhunt Tim Hunt made changes -
              Link This issue is duplicated by MDL-10031 [ MDL-10031 ]
              timhunt Tim Hunt made changes -
              Status Reopened [ 4 ] Resolved [ 5 ]
              Resolution Fixed [ 1 ]
              dougiamas Martin Dougiamas made changes -
              Status Resolved [ 5 ] Closed [ 6 ]
              dougiamas Martin Dougiamas made changes -
              Workflow jira [ 25210 ] MDL Workflow [ 59029 ]
              dougiamas Martin Dougiamas made changes -
              Workflow MDL Workflow [ 59029 ] MDL Full Workflow [ 88179 ]

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    28/Jan/09