Details

    • Type: New Feature
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Repositories
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      This meta bug lists and links all the subtasks for developing the repository API which is specified here:

      http://docs.moodle.org/en/Development:Repository_API

      Some discussion and a large number of votes is on MDL-9134

        Gliffy Diagrams

          Issue Links

          1.
          Get community consensus on the Repository API specification Sub-task Closed Martin Dougiamas
           
          2.
          Create directories and dummy files Sub-task Closed Martin Dougiamas
           
          3.
          Develop "filepicker" component in Moodleforms Sub-task Closed Dongsheng Cai
           
          4.
          Convert forms around Moodle to use filepicker/filemanager component Sub-task Closed Dongsheng Cai
           
          5.
          Develop Admin settings page Sub-task Closed Mark Nelson
           
          6.
          Add repository database table using xmldb editor Sub-task Closed Dongsheng Cai
           
          7.
          Develop base class /repository/repository.class.php Sub-task Closed Dongsheng Cai
           
          8.
          Develop Interface to add new repository instances Sub-task Closed Jérôme Mouneyrac
           
          9. Define Unit Tests for core and plugins Sub-task Open Unassigned
           
          10.
          Add tiny "preview" links under each icon that is NOT a folder Sub-task Closed Dongsheng Cai
           
          11.
          After selecting the file, show the thumbnail there Sub-task Closed Dongsheng Cai
           
          12.
          Move the PEAR stuff elsewhere from flicker plugin Sub-task Closed Dongsheng Cai
           
          13.
          Develop new repository plugins for 2.0 release Sub-task Closed Dongsheng Cai
           
          14.
          Develop documentation about how to create a new repository plugin Sub-task Closed Dongsheng Cai
           
          15.
          Need a solution for returning raw URLS (eg Youtube videos) Sub-task Closed Dongsheng Cai
           
          16.
          alfresco plugin requires PHP soap extension which is not required Sub-task Closed Dongsheng Cai
           
          17. idea: test button on repository admin page Sub-task Open Unassigned
           
          18.
          Resource type repository is now obsolete and should be removed Sub-task Closed Dongsheng Cai
           
          19.
          Filter repository instances by mime types and return value in file picker Sub-task Closed Dongsheng Cai
           
          20.
          Deleting an instance does not clean up the config options in repository_instance_config Sub-task Closed Dongsheng Cai
           
          21.
          Improve paging Sub-task Closed Dongsheng Cai
           
          22.
          Brand-new installation or upgrade from 1.9 should have "Local Files" and "Upload file" enabled Sub-task Closed Dongsheng Cai
           
          23.
          Flickr plugin (maybe others) can double up on .jpg in file names Sub-task Closed Dongsheng Cai
           
          24.
          Federatd search ignores mime-type restrictions currently active Sub-task Closed Dongsheng Cai
           
          25.
          Forum attachments currently not working at all Sub-task Closed Dongsheng Cai
           
          26.
          Move file picker code to a static javascript file Sub-task Closed Dongsheng Cai
           
          27.
          Display plugin instances based on capabilities Sub-task Closed Dongsheng Cai
           
          28.
          Filesystem repository plugin needs a name AND a directory Sub-task Closed Dongsheng Cai
           
          29.
          Filesystem repository plugin needs to clean input data Sub-task Closed Dongsheng Cai
           
          30.
          Improve usability of advimage plugin in editor Sub-task Closed Dongsheng Cai
           
          31.
          Add full support for FILE_INTERNAL and FILE_EXTERNAL to all repositories Sub-task Closed Dongsheng Cai
           
          32.
          Create a new simpler 'moodlemedia' dialog for TinyMCE Sub-task Closed Dongsheng Cai
           

            Activity

            nicolasconnault Nicolas Connault added a comment -

            Attached a proposed refactoring of repo code.

            skodak Petr Skoda added a comment -

            the latest commit http://cvs.moodle.org/moodle/repository/mahara/repository.class.php?r1=1.5&r2=1.6
            does not seem correct, there is probably problem with $PAGE not pixpath, in any case pixpath is mandatory, you should not work around it

            dongsheng Dongsheng Cai added a comment -

            I talked to Time about this issue before, the problem is, in web service, there is no moodle_page existed (exchanging json string only), do we really need to setup a useless $PAGE object just in order to use pixpath?

            leothiessen Leo Thiessen added a comment -

            MrCUTE Jr. is a simple version of a shared url/file repository that currently works for moodle 1.9.5 to provide a quick solution for shared resource needs. It provides a search box to find the shared resources you are looking for based on kewords and other data associated with the shared resource when it was entered into the MrCUTE Jr. repository.

            I flagged this as "duplicates" the repository api, based on it being the nearest match; but it doesn't do what the repository api does - rather provides a function that the repository api will enable, more fully, in the future. I hope this will solve some simpler needs for Moodle 1.9.5 users in the meantime.

            Feedback is welcomed, please!

            moerderin Nick Thompson added a comment -

            Maybe I'm missing something, but according to the specs found here:
            http://docs.moodle.org/en/Development:Repository_API

            For every file I should be able to choose to copy the file into moodle, or link to it externally.
            "only return the URL to the file if it's desired to keep it external"

            I don't see that option anywhere...

            dougiamas Martin Dougiamas added a comment -

            Nick, see MDL-20602. It's not in CVS yet.

            dougiamas Martin Dougiamas added a comment -

            Resolving the main bug as repositories are clearly in and working. Will let the few subtasks take care of themselves.

            Thanks Dongsheng and Petr and others for all your work on this!


              People

              • Votes:
                20 Vote for this issue
                Watchers:
                29 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10