What does "2" mean? I don't know. Ah – look at the HTML:
<option value="0" selected="selected">Keep internal</option>
<option value="1">Suspend internal</option>
<option value="2">Full delete internal</option>
The code should use, e.g., AUTH_REMOVEUSER_KEEP, AUTH_REMOVEUSER_SUSPEND, and AUTH_REMOVEUSER_FULLDELETE instead of 0, 1, and 2.
I'll submit a patch for 2.0 shortly, because I suppose it's not worth changing released versions. This will NOT change functionality, it will only improve code readability (which should cut down on future bug introduction, developer frustration, etc.)