Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-14095

EditingTeacher cannot edit quiz questions

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not a bug
    • Affects Version/s: 1.9
    • Fix Version/s: None
    • Component/s: Questions, Quiz
    • Labels:
      None
    • Environment:
      Any
    • Database:
      Any
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      It's not possible to edit or preview questions on a quiz. Icons that can be used to do this, normaly showed on a question list doesn't appear. Logged as moodle site administrator it's all fine, but, logged as teacher (editingteacher role) the problem occurs.

        Gliffy Diagrams

        1. quiz.png
          98 kB
        2. quiz-ok.png
          101 kB

          Activity

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Sounds important. Addressing to 1.9.1

          timhunt Tim Hunt added a comment -

          It works for me.

          On my 1.9+ test site, in a test course, as a teacher, I could create a new quiz, then create some questions and add them to the quiz, and preview them from both the quiz and the question bank.

          If this is still a problem to you, can you attach a screen-shot of the quiz editing page, and check that you have not made any non-standard changes to the roles definitions, or any roles overrides.

          tsala Helen Foster added a comment -

          Works for me too using 1.9+.

          Reopening this issue in order to resolve it as "Not a bug".

          minholi Marcelo Minholi added a comment -

          This is what is happening to me. With other themes still the same, so isn't something with the theme. I already reset all permissions to default ones and nothing happens.

          timhunt Tim Hunt added a comment -

          Do you see that message at the top of the screen: "You cannot add or remove questions because there are attempts."

          Once a student has attempted a quiz, you can no longer add or remove questions, unless you delete all the existing attempts first.

          minholi Marcelo Minholi added a comment -

          This screenshot shows what is showed when I access the same page with an Administrator account.

          minholi Marcelo Minholi added a comment -

          Hi Tim. Before the upgrade this icons are showed up normaly. In this case the Teacher don't want to add or remove questions but just edit some of the current questions text.

          timhunt Tim Hunt added a comment -

          You can edit individual questions using the edit link next to the question on the preview or review pages, or by going to the questions tab.

          minholi Marcelo Minholi added a comment - - edited

          Now I did some other tests and install a fresh moodle for it. Only Quizzes created at another version (present during upgrade) have this problem. New quizzes, created at 1.9+ version are working correctly. Certainly this is an upgrade related issue, probaly related to new permissions for this kind of activity. Please check Quiz migration and module upgrade procedures.

          Edit permissions also are affecting other screens. There is no way to edit those questions with any user with "editingteacher" role.

          tsala Helen Foster added a comment -

          Hi Marcelo,

          Good to hear you've solved the issue. Thanks for the Moodle Docs link


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: