Moodle
  1. Moodle
  2. MDL-14132

Document that database "Required entries" is not compatible with database linking filter

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.4, 1.9
    • Fix Version/s: 1.9.5
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      The problem is that the filter does not verify if user is able to see the entry.
      This can not be fixed because this filter is very expensive already and we would have to disable text caching completely.

      Workaround is to decument this in help/docs.

        Gliffy Diagrams

          Issue Links

            Activity

            Petr Skoda added a comment -

            Just a note somewhere that database linking filter does not obey this restrictions, so it should not be recommended to enable these at the same time.

            Helen Foster added a comment -

            Petr, thanks for your report.

            The following note has been added to http://docs.moodle.org/en/Adding/editing_a_database and http://docs.moodle.org/en/Filters

            Note: If entries are required before viewing, the database auto-linking filter should be disabled. This is because the database auto-linking filter can't determine whether a user has submitted the required number of entries.

            Petr Skoda added a comment -

            thanks a lot

            Sam Hemelryk added a comment -

            Should this also be commented on in the help file associated with Required Entries when creating/editing a database resource?
            /help.php?module=data&file=requiredentries.html&forcelang=

            Helen Foster added a comment -

            Good point Sam. How about we add the following note to the help file:

            Note: This feature cannot be used together with the database auto-linking filter, since it's not possible for the database auto-linking filter to determine whether a user has submitted the required number of entries.

            Helen Foster added a comment -

            Note added to requiredentriestoview.html


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: