Moodle
  1. Moodle
  2. MDL-14228

Auto-create groups - Alphabetically by id number sortng does not apear to be working

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.9
    • Fix Version/s: None
    • Component/s: Groups
    • Labels:
      None
    • Environment:
      any
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      Have reviewed using ID of user in database and ID field in profile. Allocation doesn't seem to fit the description "alphabetically by id number".

        Gliffy Diagrams

          Activity

          Hide
          Eloy Lafuente (stronk7) added a comment -

          Hi Ray,

          if I'm not wrong that isn't the user->id but the user->idnumber column (viewed as "ID number" in the profile page). Do you have information in that "ID number" field in order to be able to allow the process to effectively order by it?)

          I've performed a quick look to code (not tested) and looks ok.

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Hi Ray, if I'm not wrong that isn't the user->id but the user->idnumber column (viewed as "ID number" in the profile page). Do you have information in that "ID number" field in order to be able to allow the process to effectively order by it?) I've performed a quick look to code (not tested) and looks ok. Ciao
          Hide
          Ray Lawrence added a comment -

          Hi Eloy,

          Yes, I tested using that field too but the ordering in the auto-create preview didn't seem to take it into account. In fact I couldn't see any obvious logic as to how users had been sorted in to groups.

          Show
          Ray Lawrence added a comment - Hi Eloy, Yes, I tested using that field too but the ordering in the auto-create preview didn't seem to take it into account. In fact I couldn't see any obvious logic as to how users had been sorted in to groups.
          Hide
          Michael de Raadt added a comment -

          Thanks for reporting this issue.

          We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported.

          If you believe that this issue is still relevant to current versions (2.1 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

          Michael d;

          lqjjLKA0p6

          Show
          Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.1 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d; lqjjLKA0p6
          Hide
          Michael de Raadt added a comment -

          I'm closing this issue as it appears to have become inactive and is probably not relevant to a current supported version. If you are encountering this problem or one similar, please launch a new issue.

          Show
          Michael de Raadt added a comment - I'm closing this issue as it appears to have become inactive and is probably not relevant to a current supported version. If you are encountering this problem or one similar, please launch a new issue.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: