Moodle
  1. Moodle
  2. MDL-14235

On logging in an image appeary instead of the moodle page. always works correctly the second try.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9.1
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      FreeBSD Apache MySQL PHP
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When I sign in I get a picture on the screen from the images directory. I backup and sign in again and it works ok.

        Gliffy Diagrams

          Issue Links

            Activity

            Eloy Lafuente (stronk7) added a comment -

            Wow, curious bug. And confirmed here! To reproduce (not always):

            0) New browser
            1) Goto http://ruralu.org
            2) Press the login link
            3) In the login page, press "login as guest"
            4) What do you get?

            In 4), sometimes I got redirected back to the site page (correct) but 3 times I've been redirected to images like http://ruralu.org/file.php/6/USGS.jpg

            I only have been able to reproduce it randomly in FF (viewing 3 different images, all them present in the main page).

            Perhaps we are redirecting to something incorrect (wantsurl, or refereer, or whatever messed by requests to images?)

            Addressing to 1.9.1... curious, really curious... ciao

            Scott Provost added a comment - - edited

            The http://www.a-institute.org site on the same server (differant Moodle Installation) does the same thing.

            I have tried changing the domain name and admin/replace.php all http://ruralu.org to http://freeopenu.org
            The a-institute.org installation is now http://institute.freeopenu.org problem still happens.

            Eloy Lafuente (stronk7) added a comment -

            One more occurrence of the same problem, IMO.

            Eloy Lafuente (stronk7) added a comment -

            Hi Scott,

            I'm going to perform some research based on info facilitated at MDL-14495... the cause seems to be some image used in main page but stored within courses area. Stay tuned.

            Ciao

            Eloy Lafuente (stronk7) added a comment -

            Hi again, Scott,

            I've added one patch in MDL-14495 that seems to fix the problem under Moodle 1.9. Can you test it in your server?

            TIA and ciao

            Eloy Lafuente (stronk7) added a comment -

            Hi,

            this has been fixed under 19_STABLE and HEAD. Changes are available from CVS and will be included in next WEEKLY packages.

            See MDL-14495 for more detains about the changes implemented.

            Ciao

            Howard Miller added a comment -

            I can't get any of the reporter's sites to open to confirm the original cause. However, this sound 99% the same as the related bug which is definitely fixed, so I'm happy to close this.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: