Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.9, 2.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      IE8
    • Rank:
      1026

      Description

      IE8 beta has some problems with current css (and maybe with javascript) of current moodle. A new file for themes (styles_ie8.css) might fix the css problems or some css tags might need replacing with some other tags. http://moodle.org/mod/forum/discuss.php?d=94344

      1. Zoom.pdf
        709 kB
        Mauno Korpelainen

        Activity

        Mauno Korpelainen created issue -
        Eloy Lafuente (stronk7) added a comment -

        Assigning this to Urs... and getting subscribed to learn a bit, from this.

        Eloy Lafuente (stronk7) made changes -
        Field Original Value New Value
        Assignee Eloy Lafuente (stronk7) [ stronk7 ] Urs Hunkler [ urshunkler ]
        Eloy Lafuente (stronk7) made changes -
        Fix Version/s 1.9.1 [ 10240 ]
        Mauno Korpelainen added a comment -

        I guess the main problem is included to the attachment.

        Mauno Korpelainen made changes -
        Attachment Zoom.pdf [ 13577 ]
        Martin Dougiamas made changes -
        Fix Version/s 1.9.2 [ 10280 ]
        Fix Version/s 1.9.1 [ 10240 ]
        swissonlineacademy.com added a comment -

        Same Problem with other versions, like 1.8.2...

        Petr Škoda made changes -
        Fix Version/s 1.9.3 [ 10290 ]
        Fix Version/s 1.9.2 [ 10280 ]
        Mauno Korpelainen added a comment - - edited

        http://support.microsoft.com/kb/952030 : Adding the Internet Explorer 7 compatibility tag should address most display issues. The meta-tag causes Internet Explorer 8 to render pages in either Internet Explorer 7 Standards (Strict) mode or in Internet Explorer 5 (Quirks) mode, based on the Doctype element declaration.

        It may be better to let IE8 to "play" IE7 with

        <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

        More info in

        http://www.microsoft.com/windows/products/winfamily/ie/ie8/readiness/DevelopersExisting.htm

        Urs Hunkler added a comment -

        Never change your porgram for a Microsoft beta browser! The right time to investigate is when IE 8 is out of beta and there may be still issues.

        Mauno Korpelainen added a comment -

        Urs - IE8 Beta 2 is coming in August and the final version a little later - read http://blogs.msdn.com/ie/archive/2008/06/03/ie8-beta-2-coming-in-august.aspx :

        "...Second, make sure your site looks great in IE8; as you may recall, IE8 will use our new, more standards-compliant layout and rendering engine for strict doctype pages by default. This may cause IE8 to layout pages differently than IE7 did. If you haven't had a chance to test your pages yet or don't want to make changes yet, remember that you can have your site tell IE to use our IE7 layout engine for your strict doctype pages by adding the X-UA-Compatible http header to your HTTP headers or on a per document basis..." said by Tony Chor, IE8 Group Program Manager.

        This is just a suggestion of what to do when the final version is out - to avoid confusion when IE8 breaks many parts of css / layout of moodle.

        Urs Hunkler added a comment -

        Microsoft stuff always promise more than they hold. And they know how to do marketing writing. Look at IE7 promises and the reality. When MS has solved the issues they want we know what they left and can investigate. But never before the release date. This lesson I have learned. When you start before the release date you will have a lot of unnecessary work.

        Moodle is standard compliant - it works in FF and Opera and Safari. When IE8 is standards compliant it will work too. It's that easy.

        The IE7 compatibility mode might be a last live saver when all other approaches fail.

        Martin Dougiamas made changes -
        Fix Version/s 1.9.4 [ 10300 ]
        Fix Version/s 1.9.3 [ 10290 ]
        Urs Hunkler made changes -
        Fix Version/s 1.9.4 [ 10300 ]
        Ryan Smith added a comment -

        Just a quick update, IE8 final is now available for download.

        Mauno Korpelainen added a comment -

        OK - "stable IE8" is out and some updates in http://moodle.org/mod/forum/discuss.php?d=94344

        Zooming and css seem to be fixed but at least my IE8 (installed today) has serious problems with javascripts and particularly popups although Popup blocker is disabled.

        Petr Škoda made changes -
        Parent MDL-18645 [ 31202 ]
        Issue Type Bug [ 1 ] Sub-task [ 5 ]
        Mauno Korpelainen added a comment -

        Popup blocking is an IE8 bug - not a bug in moodle - http://tracker.moodle.org/browse/MDL-18645

        Susan Mangan added a comment -

        Can someone please advise if there will be fixes for IE 8 problems for version 1.8+?

        I first reported back in June http://tracker.moodle.org/browse/MDL-19396 but there have been no comments made.

        Our institution will not move to IE 8 until end of next yr earliest but it appears many of our faculty, and most likely our students, will have upgraded their home computers and laptops. Our school term starts in a couple of weeks and I am currently advising people to install Firefox in the interim, but still would like to know what the plans are, if any, to make v. 1.8+ compatible with IE 8.

        Thanks,

        Susan Mangan

        Martin Dougiamas made changes -
        Workflow jira [ 25813 ] MDL Workflow [ 43244 ]
        Martin Dougiamas made changes -
        Workflow MDL Workflow [ 43244 ] MDL Full Workflow [ 71645 ]
        Dan Poltawski added a comment -

        Hi,

        I am afraid we are no longer supporting 1.x branches and I am not aware of any remaining issues in 2.x so i'm closing this issue.

        Dan Poltawski made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Won't Fix [ 2 ]

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: