Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9.1
    • Component/s: Forum
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When forums are set to use separate groups, the students are not allowed into the discussion. I've only tested separate groups mode. I have the course mode set to separate and I have it forced. If I click Forums, the list of forums is not clickable for students. If I click the link to the forum from inside the course section it takes me to the discussion but I'm able to see the posts from other groups. If I click reply it gives an error that contains a link to an unknown language entry. Groups and forums seem completely broken.

        Gliffy Diagrams

          Attachments

          1. 1.png
            1.png
            4 kB
          2. 3.png
            3.png
            21 kB
          3. 4.png
            4.png
            33 kB
          4. 5.png
            5.png
            6 kB
          5. lib.php
            244 kB
          6. post.php
            33 kB
          7. view.php
            12 kB

            Issue Links

              Activity

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    15/May/08