Moodle
  1. Moodle
  2. MDL-14467

Bad link to Multiple Choice question help file

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.3, 1.9
    • Fix Version/s: 1.8.6
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE
    • Rank:
      15614

      Description

      The page for adding/editing multiple choice questions has a help button at the end of the heading pointing to [...]/help.php?module=qtype_multichoice&file=multichoice.html&forcelang= which is not a valid Moodle URL. All other questions type have this button pointing to [...]/help.php?module=quiz&file=[XYZ].html&forcelang=

      Steps to reproduce:
      1. On the course page click "Questions" in the Administration menu.
      2. Select "Multiple choice" from the "Create new question" combo box.
      3. Click the help button at the end of the heading "Adding a Multiple Choice question".

        Activity

        Tim Hunt added a comment -

        Actually, the link is right. The help file is in the wrong place. Fixed now.

        Daniel Miksik added a comment -

        Thanks for the quick fix. This should be reflected in all the language packs that have the multichoice.html file in its original location, i.e. help/quiz/multichoice.html. Could this be done automagically in CVS, or should the maintainers of the language packs do it themselves? If the answer is B, where do they get the information that they should do the move?

        Tim Hunt added a comment -

        As I understand it, Moodle's language editing tools tell translators which files exist in the English language pack, but not in their language packs, then it is up to them to supply the missing files.

        However, I may be wrong about that, because I am not an expert on the translation process. A good place to post about this would be the language forum: http://moodle.org/mod/forum/view.php?id=43. They'll know the answer. Would you be prepared to post there?

        Daniel Miksik added a comment -

        You are absolutely right, I'm a co-maintainer of the Czech lang pack, so I know where to look for it (language edit page). I was just wondering if this purely formal change could be performed in CVS "from above" in a bulk-mode fashion for all the language packs.

        Helen Foster added a comment -

        Tim, thanks for fixing this issue

        Daniel, thanks for your report and for your comments regarding moving the help file in all language packs. I've created a sub-task for this.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: