Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-14515

Feedback module is not showing up on activity reports properly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.8
    • Component/s: Feedback
    • Labels:
      None
    • Environment:
      win2k3
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      I have a feedback on the front page and have noticed, when looking at the activity report overview screen of any user who has filled it in, that there is nothing there. When I go to all logs, however, I can see that they have viewed and filled it in.

        Gliffy Diagrams

          Attachments

            Activity

            Hide
            grabs Andreas Grabs added a comment -

            Are there some errors while debug-mode is on?
            Can you tell me the full version-number of the feedback?

            Show
            grabs Andreas Grabs added a comment - Are there some errors while debug-mode is on? Can you tell me the full version-number of the feedback?
            Hide
            mattgibson Matt Gibson added a comment -

            Version is 2007073101

            Forgot to turn debugging on before. With debugging set to full, I get:

            On main feedback page:

            print_header() was sent a string as 3rd ( Feedback Activities -> Staff ICTAC survey) parameter. This is deprecated in favour of an array built by build_navigation(). Please upgrade your code.

            • line 2382 of lib\weblib.php: call to debugging()
            • line 75 of mod\feedback\view.php: call to print_header()

            On show responses page:

            Navigation needs to be updated to use build_navigation()

            • line 3581 of lib\weblib.php: call to debugging()
            • line 102 of theme\pen_and_ink_4\header.html: call to print_navigation()
            • line 2592 of lib\weblib.php: call to include()
            • line 93 of mod\feedback\show_entries.php: call to print_header()

            On show analysis page:

            print_header() was sent a string as 3rd ( Feedback Activities -> Staff ICTAC survey) parameter. This is deprecated in favour of an array built by build_navigation(). Please upgrade your code.

            • line 2382 of lib\weblib.php: call to debugging()
            • line 62 of mod\feedback\analysis_course.php: call to print_header()

            The one that causes the problem on the activity outline page is:

            Notice: Undefined variable: return in E:\Moodle_webserver\moodle\mod\feedback\lib.php on line 141

            Show
            mattgibson Matt Gibson added a comment - Version is 2007073101 Forgot to turn debugging on before. With debugging set to full, I get: On main feedback page: print_header() was sent a string as 3rd ( Feedback Activities -> Staff ICTAC survey) parameter. This is deprecated in favour of an array built by build_navigation(). Please upgrade your code. line 2382 of lib\weblib.php: call to debugging() line 75 of mod\feedback\view.php: call to print_header() On show responses page: Navigation needs to be updated to use build_navigation() line 3581 of lib\weblib.php: call to debugging() line 102 of theme\pen_and_ink_4\header.html: call to print_navigation() line 2592 of lib\weblib.php: call to include() line 93 of mod\feedback\show_entries.php: call to print_header() On show analysis page: print_header() was sent a string as 3rd ( Feedback Activities -> Staff ICTAC survey) parameter. This is deprecated in favour of an array built by build_navigation(). Please upgrade your code. line 2382 of lib\weblib.php: call to debugging() line 62 of mod\feedback\analysis_course.php: call to print_header() The one that causes the problem on the activity outline page is: Notice: Undefined variable: return in E:\Moodle_webserver\moodle\mod\feedback\lib.php on line 141
            Hide
            emb03 Elaine Blakeman added a comment -

            I have a Questionnaire Activity on the Front Page and for the life of me I cannot find a way to view activity for the Questionnaires (to see who has taken it). I can only see Recent Activity for the past one hour. Is there a way to view Reports for single Activities on the Front Page? I only get activity links to forums not Questionnaires...

            Show
            emb03 Elaine Blakeman added a comment - I have a Questionnaire Activity on the Front Page and for the life of me I cannot find a way to view activity for the Questionnaires (to see who has taken it). I can only see Recent Activity for the past one hour. Is there a way to view Reports for single Activities on the Front Page? I only get activity links to forums not Questionnaires...
            Hide
            grabs Andreas Grabs added a comment -

            I think it is resolved.
            It seams to be related to MDL-15587.
            Best regards
            Andreas

            Show
            grabs Andreas Grabs added a comment - I think it is resolved. It seams to be related to MDL-15587 . Best regards Andreas

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/Mar/12