Moodle
  1. Moodle
  2. MDL-14558

Users can get subscribed to the forum where subscription not allowed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.8.5, 1.9
    • Fix Version/s: 1.8.8, 1.9.4
    • Component/s: Forum
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Rank:
      30978

      Description

      If the forum set in 'Subscriptions not allowed' mode user still can see subscription menu when posting (adding discussion or replying) and get subscribed on it. It can get unsubscribed only during another post then.

      1. fixsubscription.php
        1 kB
        Mathieu Petit-Clair
      2. patch-14558-forum_subscribe.new.18_STABLE.patch
        4 kB
        Mathieu Petit-Clair
      3. patch-14558-forum_subscribe.new.patch
        4 kB
        Mathieu Petit-Clair

        Issue Links

          Activity

          Thomas Robb added a comment -

          This problem also occurs in version 1.8.4. it is particularly vexing because the default value is "Yes" and the students have no way to unsubscribe. Can it be fixed?

          Eloy Lafuente (stronk7) added a comment -

          Assigning this to Petr... raising to Major and adding both 1.8 and 1.9 fixfor versions.

          Oleg Sychev added a comment -

          Thomas - you students still can unsubscribe using the same method throught which they get subscribed: creating new post and setting the value to "No". But this is pretty confusing.

          Thomas Robb added a comment -

          Hello, Oleg,

          Yes, your round-about method might work, but we have 12,000 students using Moodle and there is no good way of informing all of them of this trick!

          Oleg Sychev added a comment -

          Hello, Thomas.

          I'm too want to have this issue removed (or I don't reported it). You may vote for it, if you want it to get more attention.

          By the way, in 1.9. you can set default value to 'No' in user settings. We found this feature very useful.

          Thomas Robb added a comment -

          Hello, I just got a query from my univesity's network center wondering if anything was happening with regard to this bug report. It is still a serious issue here.

          Oleg Sychev added a comment -

          Hello, Thomas!

          As it seems, you method doesn't work: it seems, that Petr now is quite busy with database access code upgrade in the HEAD.

          So please vote for the issue, and motivate you network center add votes too - the more votes it get, the faster will be solution.

          Ted O'Neill added a comment -

          If this is not fixed it will force users off Moodle at my school.

          This issue is extremely significant. Forums are a core module and perhaps the most used at my university. We have 8,000 plus students. In my own department we have 80 plus staff, so as Tom said above, teaching a work around is just not practical.

          So many students (and many staff) have university mail forwarded to their phones. Getting several hundred email messages at all hours of the day and night has already turned off one user. It will drive away the rest in short order.

          Rich H added a comment -

          Truly a disaster!

          I am now forced to have second thoughts about using Moodle this semester. I can only begin to imaging the horror and inconvenience that this will cause.

          Please, please fix it - or hundreds of teachers and thousands of students will be driven away from Moodle.

          Simon Hunter added a comment -

          This is indeed a major bug. It will have a huge impact on the usage of Moodle at my university. Getting these unwanted emails causes such angst that faculty and students will stop using Moodle. I can't think of anything more serious than that!

          Martin Dougiamas added a comment -

          Mat can you come up with a patch?

          Martin Dougiamas added a comment -

          I guess the correct solution would be

          if "disallow subscription" is set then

          • don't show the menu
          • don't process that field in the submission for that field

          I'm not sure if we want to go through and forceunsubscribe everyone who might already be subscribed to such forums. There might be cases where people want to retain the existing subscriptions yet not allow new ones, but I guess these would be few.

          The alternative is not to forceunsubscribe anyone and provide admins with a small fixup script to go through and perform the deletions. The trouble is this is not the sort of thing that should be in the distribution, and it it's difficult to add anywhere in the interfaces, people would have to find it here.

          We could also add a "delete all subscriptions" button to the forum page but then people would have to go through and hit it for all forums on a perhaps large site ...

          So I tend towards deleting all the existing subscriptions and let people deal with the perhaps unwanted dataloss.

          Any thoughts about this from anyone?

          Mathieu Petit-Clair added a comment -

          This bug seems to occur only for accounts having "moodle/course:manageactivities" capability, where these users are presented with a form that defaults to "send me email copies...". I can't reproduce for a student account (an account without that capability) in 1.8, 1.9 or head.

          Attaching a patch that makes the default selection "I don't want emails..." for users having that capability when posting in a forum not allowing subscriptions. Please review & test (patch against head, also applies on 1.9, use the MOODLE_18 file for 1.8).

          If the problem is indeed for every account / not linked to this capability, we will need more information to reproduce it.

          Ray Lawrence added a comment -

          Does the patch set the default or disable that option with the no email option enforced?

          Ideally when subscriptions are not allowed the interface for doing so should not be visible or replaced with text to that effect (there are numerous other examples in the interface where this approach is taken). Of course this doesn't help with correcting the existing problem behaviour.

          Mathieu Petit-Clair added a comment -

          Can you try the following query:

          SELECT f.id, s.userid FROM mdl_forum_subscriptions s JOIN mdl_forum f ON s.forum = f.id WHERE f.forcesubscribe = 3

          and tell me (either here or by private email) how many wrong subscriptions are actually recorded in your database? (I'd like to get an idea of the size of the problem on a real dataset)

          Bill Burgos added a comment -

          Hi Mathieu,

          On one of our sites, we have 447 records listed in this query.

          Bill

          Mathieu Petit-Clair added a comment -

          Hi Bill,

          I would like some more information about the forum/course where this is happening: is it only in one forum? ..and what type of forum? Can you confirm that these (well, at least one) of these users do not have the manageactivities capability? On which version of Moodle are you seeing this bug?

          I clearly do not have the same setup - it's working as it should on my side.

          Gary Barclay added a comment -

          Hi All,

          To add my 2 cents worth. This happens for me on all my forums in all my courses. Setting a forum to 'Subscriptions not allowed', when a user posts, instead of the drop down box proviing email options, they see text saying 'subscriptions' not allowed'. However once they post they receive notification that they will receive posts by email, and they are added to the subscribed list and email new posts.

          I just tested overriding permissions to prevent manageactivities and the bug remianed.

          I am using Moodle 1.9.

          Gary

          Oleg Sychev added a comment -

          HI, Martin,

          You wrote:
          >>I'm not sure if we want to go through and forceunsubscribe everyone who might already be subscribed to such forums. There might be cases where people want to retain the existing subscriptions yet not allow new ones, but I guess these would be few.

          >>The alternative is not to forceunsubscribe anyone and provide admins with a small fixup script to go through and perform the deletions. The trouble is this is not the sort of thing that should be in the distribution, and it it's difficult to add anywhere in the interfaces, people would have to find it here.

          >>We could also add a "delete all subscriptions" button to the forum page but then people would have to go through and hit it for all forums on a perhaps large site ...

          >>So I tend towards deleting all the existing subscriptions and let people deal with the perhaps unwanted dataloss.

          >>Any thoughts about this from anyone?

          Why don't bump forum version and include fixup script in upgrade.php (maybe with a question, is admin want to execute it)?

          I think, that button "delete all subscriptions" will be useful anyway (maybe on the participants page), also maybe Moodle can ask a user, if they want to delete all subscriptions when there is subscribtions in the forum and the user change forum status to "Subscription not allowed".

          Mathieu Petit-Clair added a comment - - edited

          Has any change been done to capabilities mod/forum:initialsubscriptions and mod/forum:managesubscriptions on affected sites? Can someone send me (privately...) an admin login to an affected site? I still can't reproduce locally.

          Also, I'd like to know the exact version & build (available in /version.php) of affected sites.

          Mathieu Petit-Clair added a comment -

          Ok, I can reproduce - found the bug, on my way to fixing it.

          Ted O'Neill added a comment -

          Hi All,

          Thanks very much for getting this issue moving along. Gives me a lot more confidence when teachers in my department ask me about Moodle!

          Ted

          Mathieu Petit-Clair added a comment -

          Here's a new patch (in attached file "patch-14558-forum_subscribe.new.patch"), against Moodle 1.9. I tested this and believe it stop the issue (new posters don't get subscribed to no-subscription forums). Please test & comment - I'll commit to CVS when it gets some good review.

          Starting work on a cleanup script.

          Mathieu Petit-Clair added a comment -

          Attached script "fixsubscription.php", which cleans up database. Obviously, the first patch should be applied, otherwise wrong data will keep getting added.

          This script defaults to a "test run" mode that displays userids that would be unsubscribed. It doesn't unsubscribe people that have permission to subscribe otherwise. They can either unsubscribe themselves if they want, or you can modify the script to unsubscribe everybody in these forums.

          I strongly suggest making a backup of table forum_subscriptions first, at least until people have confirmed this is working as it should (I tested this, but my data set is quite small).

          This script works on 1.8. and 1.9.

          Bill Burgos added a comment -

          Hi,

          Is the patch good for version 1.8.6?

          We seem to be getting error when applying them to a 1.8 site.

          Or, could we get the modified files?

          Bill

          Mathieu Petit-Clair added a comment -

          Here's a new patch for 1.8 - See file patch-14558-forum_subscribe.new.18_STABLE.patch

          Mathieu Petit-Clair added a comment -

          I'm waiting for a confirmation that this works for other people (and not just me) to commit it to CVS. 1.9.3 will be released next week...

          Bill Burgos added a comment -

          Hi,

          Testing on a patched 1.8 site.

          User can still subscribe to Forums of which have been set to "Subscriptions not allowed".

          1. Go to top of Course

          2. Click on 'Forums' under the Activities Menu

          3. In the upper right, click on 'Subscribe to all forums'

          4. User is now subscribed to all forums regardless of initial setting by teacher.

          5. User can now unsubscribe to selected forums.

          6. User can now go to a forum set to 'Subscriptions not allowed' and post a reply. The same user will receive their own post. Other users in the course do not.

          Checking for the same on a patched 1.9 site...

          Bill

          Mathieu Petit-Clair added a comment -

          Thanks for this review Bill, sorry I forgot to correct this link. I'll update the patch later on.

          Mathieu Petit-Clair added a comment -

          This has been committed to 1.8 & 1.9. Keeping this open - need to create an update stanza for the cleanup script (which itself needs to be improved, following a discussion with Eloy).

          Jet Hall added a comment -

          We have this problem on our site and it seems to only occur sporadically. I asked one of the users how he was able to subscribe to all forums even though subscription is disabled. He said after clicking on a discussion in one of the forums, the "subscribe to all forums" button appeared and he clicked on it. We have over 300 users and this occurred on a single day for about 9 of them before I caught it. Because I am a relative newbie and don't know how to run a patch, I manually deleted all subscriptions in the database and that seemed to stop the problem pretty well, but did not eliminate it completely. It occurred again a few days later and 1 user was able to subscribe to all forums. I deleted those subscriptions and now a few weeks have passed with no further subscriptions.

          Mathieu Petit-Clair added a comment -

          Here's a new version of the cleanup script that uses less queries. This script has been tested in 1.9 (should work in 1.8 as well). Would need modifications to work in head (to use the correct database calls).

          I am not sure how (or event if it's possible) to check for a capability without using functions from accesslib, which afaik should not be used in upgrade.php.

          Martin Dougiamas added a comment -

          There is a problem with 1.8 with a bad function call causing posting not to work in 1.8.7.

          http://moodle.org/mod/forum/discuss.php?d=108224

          Seems to be related to the patch in this bug.

          Dongsheng, since Mathieu is away can you please urgently check this and make corrections to 1.8? Possibly the patch is incomplete.

          I'll retag 1.8.7 later today. Thanks!

          Dongsheng Cai added a comment -

          Martin, I cannot reproduce this, the function calls are correct on 1.8.7.

          Martin Dougiamas added a comment -

          Hmm, then what is happening? See MDL-16925

          Eloy Lafuente (stronk7) added a comment - - edited

          Just guessing if the fix applied in MDL-16925 will also fix this. Can you confirm if it's working now (by updating from CVS or downloading 1.8 packages).

          Ciao

          P.S.: The bug didn't seem to be present in 1.9, only in 1.8

          Dongsheng Cai added a comment -
          José Coelho added a comment -

          I could reproduce this problem using the lastest version 1.9.5+.

          I do the following:
          1- create a forum named TEST with "Force everyone to be subscribed? = Subscriptions not allowed"
          2- in the user profile set: "Forum auto-subscribe = Yes, when I post subscribe me to that forum"
          3- rank down premissions to student and send a message in the forum TEST

          The menu to subscribe does not appear, but after sending the post, the user subscribe the forum, and then an email is send.

          If I understand correctly, I need to apply the MDL-16025. The function in MDL-16025 (function forum_is_subscribed), is equal to the source code I have.

          Why not insert in this function an extra condition for the forum is not in the mode of "Subscriptions not allowed"? This would exclude all users from a forum that does not allow subscriptions, and solve my problem.

          The production site is in the 1.9.1 version, and we now have some foruns with 3000 students, that lead to many emails, resulting in several problems.

          Regards,
          José Coelho


            People

            • Votes:
              10 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: