Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-14625

Make multianswer questions more tolerant if one of the subquestions is missing

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9.10
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Multianswer question broken in latest weekly builds.

      Trying to use exitsting questions I receive fatal error: Call to a member function get_correct_responses() on a non-object in /hosts/edu/www/question/type/multianswer/questiontype.php on line 252

      Trying to create new questions results in errors strings from Moodle such as "questiontype numerical not recognized". (shortasnwer question too).

        Attachments

        1. edit_multianswer_form.php
          13 kB
          Pierre Pichet
        2. edit_multianswer_form.php
          12 kB
          Pierre Pichet
        3. questiontype.php
          36 kB
          Pierre Pichet
        4. questiontype.php
          35 kB
          Pierre Pichet
        5. quiz-multianswer-warning-positionkey-test-1.9.4.patch
          0.9 kB
          Tim Lock

          Issue Links

            Activity

              People

              Assignee:
              ppichet Pierre Pichet
              Reporter:
              oa_sychev Oleg Sychev
              Participants:
              Component watchers:
              Tim Hunt, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              2 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                25/Oct/10