Moodle
  1. Moodle
  2. MDL-14979

decide if quizfile.php still used and remove if not

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.1
    • Fix Version/s: 1.9.3
    • Component/s: Quiz
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      26418

      Activity

      Tim Hunt added a comment -

      Yes, this file is completely obsolete. It has not been used since the refactor that moved the question bank out of the quiz between Moodle 1.5 and 1.6. There is an associated obsolete method uses_quizfile that was only remaining in question/type/datasetdependent/abstractqtype.php, and which I removed too.

      The only trace I could find of references to this code was in contrib/old/..., in two packages that are not supposed to work with modern Moodles anyway.

      Mathieu Petit-Clair added a comment -

      Grep, not found, all good. Closed. Could this be removed from 1.6-1.8 as well?

      Tim Hunt added a comment -

      I think it is better not to do code clean-ups on stable branches. The main benefit of cleaning up the code is that it makes future development easier, but there is always the risk of causing a regressions. Therefore it makes sense on HEAD, but not on the stable branches. I don't really know why I applied this to 1.9 even.


        People

        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: