Moodle
  1. Moodle
  2. MDL-15119

Networking: cannot connect to a remote Moodle on the same server - Segmentation Fault

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.1
    • Fix Version/s: 1.9.2
    • Component/s: MNet
    • Labels:
      None
    • Environment:
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      24418

      Description

      The administrator installed two Moodles on the same server. The Moodle Networking configuration was successfull. But when he tries to connect to a remote server (Network Servers block), the following error is displayed:

      RPC auth/mnet/user_authorise:Empty reply from serverERROR 52:52:Empty reply from server

      If we look in the php error logs we'll see a segmentation fault for Apache.

      This error is reproduced on a clean site, latest Weekly code (21 May 2008), and clean database.
      I couldn't reproduce the bug on my machine.

      Funny stuff:
      I added different error_log/trigger_error messages in the code. When I added these log messages the segmentation fault didn't appear at the same moment.

      First the xmlrpc server send an empty answer, and we get a segmentation fault.
      After putting some log messages, the xmlrpc client received an answer. The segmentation fault appeared later.
      After putting even more log messages, the connection worked!
      Then we came back to original files (server.php and client.php in mnet/xmlrpc). Same error than first.
      Then we put back again the files which used to work => it didn't work anymore, still a segmentation fault, somewhere else.

        Activity

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: