Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-15182

LDAP enrolment course auto-creation doesn't work at user login

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.5, 1.9.1
    • Fix Version/s: 1.8.6, 1.9.2
    • Component/s: Enrolments
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      We use $this->create_course() to create the non-existent course, which returns the 'id' of the new record. And then we call get_record() using that value to match the field specified in $this->enrol_localcoursefield, which is wrong. We need to match the value to the 'id' field, obviously.

      Sauldos. Iñaki.

        Gliffy Diagrams

          Attachments

            Activity

            Hide
            iarenaza Iñaki Arenaza added a comment -

            Patches committed into CVS for 1.8, 1.9 and HEAD.

            Saludos. Iñaki.

            Show
            iarenaza Iñaki Arenaza added a comment - Patches committed into CVS for 1.8, 1.9 and HEAD. Saludos. Iñaki.
            Hide
            skodak Petr Skoda added a comment -

            thanks

            Show
            skodak Petr Skoda added a comment - thanks

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jul/08