Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-15410

Require PHP 5.2.4 instead of 5.2.0 in HEAD

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Course
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Using Moodle 2.0 dev (Build: 20080625)
      impossible to display Participants list, with debug on I get the following errors:
      ---------
      Notice: Indirect modification of overloaded property moodle_session::$flextable has no effect in moodle\lib\tablelib.php on line 360

      Notice: Indirect modification of overloaded property moodle_session::$flextable has no effect in moodle\lib\tablelib.php on line 361

      Notice: Indirect modification of overloaded property moodle_session::$flextable has no effect in moodle\lib\tablelib.php on line 362

      Notice: Indirect modification of overloaded property moodle_session::$flextable has no effect in moodle\lib\tablelib.php on line 363

      Notice: Indirect modification of overloaded property moodle_session::$flextable has no effect in moodle\lib\tablelib.php on line 364

      Notice: Indirect modification of overloaded property moodle_session::$flextable has no effect in moodle\lib\tablelib.php on line 365

      Notice: Indirect modification of overloaded property moodle_session::$flextable has no effect in moodle\lib\tablelib.php on line 368

      Warning: Attempt to assign property of non-object in moodle\lib\tablelib.php on line 417

      Warning: array_reverse() [function.array-reverse]: The argument should be an array in moodle\lib\accesslib.php on line 3469

      Warning: Illegal offset type in isset or empty in moodle\lib\accesslib.php on line 467

      Warning: Attempt to assign property of non-object in moodle\lib\adodb\adodb.inc.php on line 1820

      Warning: implode() [function.implode]: Bad arguments. in moodle\lib\accesslib.php on line 1170

      Fatal error: Cannot redeclare _rs2serialize() (previously declared in moodle\lib\adodb\adodb-csvlib.inc.php:34) in moodle\lib\adodb\adodb-csvlib.inc.php on line 79

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              this should be already fixed several days ago, could you please test fresh cvs checkout?

              rezeau Joseph Rézeau added a comment -

              I just did an update (I'm using ECLIPSE CVS), and am still getting the error messages...
              Joseph

              skodak Petr Skoda added a comment -

              what PHP version are you using?
              What exact version is your lib/sessionlib.php?

              rezeau Joseph Rézeau added a comment -

              using PHP Version 5.2.0
              <?php //$Id: sessionlib.php,v 1.2 2008/06/22 11:56:01 skodak Exp $

              skodak Petr Skoda added a comment -

              hmm, this is caused by bug in php 5.2.0 - http://bugs.php.net/bug.php?id=39449 - fixed in PHP 5.2.1

              There are two options:
              1/ try to workaround all those hundreds of nasty bugs in PHP 5.2.0, 5.2.1, 5.2.2 and 5.2.3
              2/ or raise the minimum PHP version to at least PHP 5.2.4 for Moodle 2.0

              my +1 for option 2)

              stronk7 Eloy Lafuente (stronk7) added a comment -

              my +1 too (5.2.4 was released 30-August-2007)

              Ciao

              rezeau Joseph Rézeau added a comment -

              OK, I will upgrade to PHP 5.2.4,
              Thanks
              Joseph

              rezeau Joseph Rézeau added a comment -

              OK, just installed PHP 5.2.5 and the problem has disappeared,
              Joseph

              skodak Petr Skoda added a comment -

              Solutions are:
              1/ support old & buggy PHP version - session related code would need to be rewritten again
              2/ require PHP 5.2.4 or later

              mchurch Mike Churchward added a comment -

              Something should be decided soon. Moodle environment checks reports that Moodle requires PHP 5.2.0. But according to this bug and related bugs, it will not run without a minimum of 5.2.4. If this is the case, we really should be specifying and checking for that version.

              skodak Petr Skoda added a comment -

              yes, we should decide this asap

              skodak Petr Skoda added a comment -

              PHP version requirement changed in HEAD? now waiting for Eloy to confirm needed changes in other branches - is admin/enviroment.xml the only thing that needs to be done or something more on moodle.org?

              skodak Petr Skoda added a comment -

              done, PHP 5.2.4 is now minimal req for Moodle 2.0

              please note that we could in theory lower it again, but anybody who suggests it will be responsible for testing and bugfixing in PHP 5.2.0-5.2.3

              pilpi Olli Savolainen added a comment -

              Debian stable only includes 5.2.0, so this is bound to be a big issue for those who

              • are running Moodle on a hosted system and thus cannot upgrade and
              • don't have the skills to compile PHP by themselves.

              http://packages.debian.org/stable/web/php5

              skodak Petr Skoda added a comment -

              Olli, does that mean you are volunteering to do all the workarounds, bugfixing and testing?

              korpelainen Mauno Korpelainen added a comment -

              Olli, I have done the normal upgrading to my Debian stable (Etch) a couple of times and current version of php is probably 5.2.6

              Upgrading has never taken many minutes...


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: