Moodle
  1. Moodle
  2. MDL-15463

Language: Scalestip needs to be updated

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9.2
    • Fix Version/s: None
    • Component/s: Language
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      12592

      Description

      In /lang/en_utf8/moodle.php the scalestip string provides inaccurate directions which should be clarified or removed to avoid confusion for users.

      $string['scalestip'] = 'To create custom scales, use the \'Scales...\' link in your course administration menu.';

      As of 1.9, there is no Scales link in the course administration menu. Instead, users select grades and then choose the option for Edit Scales from the Choose an Action dropdown. This is properly described in docs and the tip just needs to be updated to reflect http://docs.moodle.org/en/Scales#Creating_a_new_scale

      Perhaps something like:

      $string['scalestip'] = 'To create custom scales, click on the Grades link in the course Administration block and then select Scales from the Edit section of the grader report Choose an action dropdown list.';

      As a point of usability and consistency for tips, should we put quotations around quoted options such as Grades, Scales, Choose an action, etc. In other words, visually it might help make it clearer if we began distinguishing actual quoted strings. So, perhaps it should be:

      $string['scalestip'] = 'To create custom scales, click on the \'Grades\' link in the course \'Administration\' block and then select \'Scales\' from the \'Edit\' section of the grader report \'Choose an action\' dropdown list.';

      I also noticed a reference to administration menu which is not 100% accurate. It is really the Administration block (not a menu). I think being consistent and accurate with the language will help improve usability and reduce questions. I'm going to add the GSOC student on this as I suspect this might be an easy thing to do to improve usability.

      Peace - Anthony

        Issue Links

          Activity

          Anthony Borrow added a comment -

          Koen - I was tempted to just change this but I couldn't remember the process for changing lang files so I thought an issue would be the best way. I vaguely recall being referred at one point to set of instructions regarding the process but forget where it was and could not find it in a quick search. Does such a page sound familiar? If so, if you could provide a URL I would be happy to review it. Peace - Anthony

          Koen Roggemans added a comment -

          Since this is not a minor edit, the strings should be replaced by new strings to maintain backwards compatibility of the language packs.
          http://docs.moodle.org/en/Development:Coding#General_rules , rule nr 12

          Koen Roggemans added a comment -

          Do you finnish this of Anthony? I'm not confident to change the code.

          Anthony Borrow added a comment -

          Koen - No I have not looked at this in a while as it was not on my active radar (i.e. I had completely forgotten about it ). I'll work up a patch as a proposed fix and run it by you for review before I check it in. Hopefully I will have some time later this week to do that. Peace - Anthony

          Anthony Borrow added a comment -

          Looks like Tim found this and fixed it already. Peace - Anthony

          Anthony Borrow added a comment -

          Koen - Looks like Tim already fixed this with MDL-18044. I did find one reference to the old string that I suspect Tim missed so I have changed that from scalestip to the newer and more accurate scalestip2. Peace - Anthony

          Anthony Borrow added a comment -

          resolving as duplicate of MDL-18044


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: