Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-15500

Lots of warning messages when turn on the Debug messages (NORMAL: Show errors, warnings and notices)

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9, 1.9.1
    • Fix Version/s: 1.9.2
    • Component/s: Libraries, Usability
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When access the "Site Administration" block (login as admin) and try to "Add a new user" (or do something in the Accounts area), if you turn on the debugging mode (see screenshots), you will get a lot of warning messages. Seems like lib/weblib.php could use some clean up maybe...

        Attachments

        1. debug_setting.png
          24 kB
          Wen Hao Chuang
        2. warning_messages.png
          27 kB
          Wen Hao Chuang

          Issue Links

            Activity

              People

              • Assignee:
                dongsheng Dongsheng Cai
                Reporter:
                chuang Wen Hao Chuang
                Tester:
                Petr Skoda
                Participants:
                Component watchers:
                Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón, Barbara Ramiro, Jake Dallimore, Jun Pataleta
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jul/08