Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-15504

Grade category lost during course restore

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.1
    • Fix Version/s: 1.9.2
    • Component/s: Gradebook
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When backing up and restoring course containing grade categories, grade categories are lost.

      Grade items and calculations are correctly restored. Version: Moodle 1.9.1+ (Build: 20080618)

      To reproduce the bug:
      1. in a course create grade categories
      2. add items and calculations at will
      3. backup the course without users
      4. restore the course
      5. grade categories are lost, items and calculations mantained

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda added a comment -

            should be fixed in cvs since yesterday, please test and reopen if needed, thanks

            andreabix Andrea Bicciolo added a comment -

            Hi Petr, just tested with 1.9 build 20080702, same problem.
            Reopening.

            skodak Petr Skoda added a comment -

            retested and works fine for me.
            please note that old backups can not work because they lack the category info.

            How did you test it?

            andreabix Andrea Bicciolo added a comment -

            Petr, we tested as follows:

            1. we created a backup of a course using Moodle 1.9 build 20080702. Course contains grade categories as well as calculated grade items
            2. we restored the course on the very same Moodle
            3. we checked the Gradebook an teh category we created are no more present.
            4. dulcis in fundo, also some calculation formula is lost.

            If needed, we can test together.

            skodak Petr Skoda added a comment -

            hmm, either that build does not contain my patch or there is another bug hidden somewhere, I can not reproduce it anymore

            the correct file version is:
            <?php //$Id: backuplib.php,v 1.179.2.32 2008/07/02 22:46:33 skodak Exp $

            andreabix Andrea Bicciolo added a comment -

            Thanks Petr, then I think the "Weekly" build is affected: <?php //$Id: backuplib.php,v 1.179.2.31 2008/05/29 02:02:39 danmarsden Exp is what i get from backuplib.php in moodle_19_weekly.

            Your version is present in moodle_19_stable.

            skodak Petr Skoda added a comment -

            ok, it means you tested version without my patch, resolving again.
            Please reopen if I misunderstood you or there is another problem, thanks!

            ltmert mert gokkaya added a comment -

            backup restore problem, correct backuplib.php version. Tried with and without assignments but still could not get the categories restored may be even backedup


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jul/08