Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-1553

Empty jump menu gives error viewing user profile

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_13_STABLE

      Description

      ver is 1.3.1)

      If Site News is invisible, and a viewer's profile is viewed from a link on the home page logged on as ......, then the error Warning: Invalid argument supplied for foreach() in /var/www/html/moodle/lib/weblib.php on line 456 is returned on screen, as the jump menu will be empty and there will be no options. If Site News is visible then this does not appear, as there is a single entry Site News in the jump menu.

        Gliffy Diagrams

          Activity

          dougiamas Martin Dougiamas added a comment -

          From Gustav Delius (gwd2 at york.ac.uk) Wednesday, 9 June 2004, 05:01 AM:

          I don't quite understand. When I view my profile there is no jump menu displayed and therefore I don't get that error. What page are you on when you get that error due to an empty jump menu?

          From Robin (rbn at iname.com) Wednesday, 9 June 2004, 03:34 PM:

          Frontpage is set to Show a list of categories and Site News is turned off. After logging in, when I clcik the link you are logged in as xxxxx at the top of the page that is when I get the error. If logged in as Admin the error doesn;t occur as the site news although set to invisible is accessible. If I make the site news visible then no error for anyone.

          From Gustav Delius (gwd2 at york.ac.uk) Wednesday, 9 June 2004, 04:38 PM:

          Fixed in 1.3 and 1.4dev.

          Thanks for explaining this to me so patiently. I had difficulties reproducing it at first because instead of hiding the news forum I had deleted it in which case the error did not occur.

          mblake Michael Blake added a comment -

          assign to a valid user


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: