Moodle
  1. Moodle
  2. MDL-15556

Site Admin Block does not appear for Course creator

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2, 1.9
    • Fix Version/s: 1.9.4
    • Component/s: Roles / Access
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      As I understand it, the fact that the site admin block does not appear for someone who is assigned course creator role has been identified as a bug in 1.7 and 1.8 and was reported fixed. However, in 1.8.2 and 1.9 the problem still is there. Gordon posted a hack to fix this in MDL-9398 and I assumed that would have meant that 1.8.2 and 1.9 would reflect a fix, but no joy.....

      http://tracker.moodle.org/browse/MDL-9398
      http://tracker.moodle.org/browse/MDL-7384

        Gliffy Diagrams

          Activity

          Hide
          Tim Hunt added a comment -

          Grabbing a bunch of related course category editing bugs that I plan to work on. Sorry for all the emails.

          Show
          Tim Hunt added a comment - Grabbing a bunch of related course category editing bugs that I plan to work on. Sorry for all the emails.
          Hide
          Helen Foster added a comment -

          Marc, thanks for reporting this issue, and Tim, thanks for fixing it

          Show
          Helen Foster added a comment - Marc, thanks for reporting this issue, and Tim, thanks for fixing it

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: