Moodle
  1. Moodle
  2. MDL-1571

When mixing courses using the restore utility, existing wiki links are broken...

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: None
    • Component/s: Backup
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_13_STABLE
    • Rank:
      8299

      Description

      You have course A containing wiki posts and/or resources. It's restored ok and wiki links are decoded fine.

      But, if you restore course B over A (adding data), course A wikis are re-decoded and links are broken.

      Solution: Decode only imported wikis, so a check must be done againt backup tables to verify that the post/resource belongs to the current backup file.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Eloy Lafuente (stronk7 at moodle.org) Thursday, 8 July 2004, 02:06 PM:

        Done in 1.3 and 1.4.

        Seems to work. I'll close it in some days...

        From Eloy Lafuente (stronk7 at moodle.org) Monday, 12 July 2004, 10:13 PM:

        No news here, so I close it now.

        Show
        Martin Dougiamas added a comment - From Eloy Lafuente (stronk7 at moodle.org) Thursday, 8 July 2004, 02:06 PM: Done in 1.3 and 1.4. Seems to work. I'll close it in some days... From Eloy Lafuente (stronk7 at moodle.org) Monday, 12 July 2004, 10:13 PM: No news here, so I close it now.
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: