Moodle
  1. Moodle
  2. MDL-15773

'Pass by reference' errors in upgrade (weblib) for old PHP versions

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.3
    • Fix Version/s: 1.9.3
    • Component/s: Libraries
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      31278

      Description

      In a few places in weblib, there have been calls to end() which pass in a function result. In old php versions eg 5.0.4 (don't know about 4.x), this causes an error because the parameter is a reference variable.

      While 5.0.4 is not allowed for moodle anyway, this happens before you get to the screen with the warning telling you to use a different php version, so I think it should be fixed... (and maybe it applies to 4.x too).

        Activity

        Sam Marshall added a comment -

        Fixed by using intermediate variables.

        (Note: Yes I know it's Tuesday but this is fixing a regression; Petr gave +1)

        David Mudrak added a comment -

        See http://php.net/manual/en/function.end.php for reference of this issue. Closing, thanks.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: