Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a bug
    • Affects Version/s: 1.8.2
    • Fix Version/s: None
    • Component/s: Administration
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Rank:
      9452

      Description

      I found that the moodle system has a wrong list of country names.
      Taiwan is not a Province of China.
      Could the moodle system take care this issue.
      Thank you.

        Issue Links

          Activity

          Eloy Lafuente (stronk7) added a comment -

          Assigning to Mathieu... I remember he did some countries cleanup some time ago.

          Ciao

          Mathieu Petit-Clair added a comment -

          Moodle has chosen to follow the ISO 3166 country list, which is generally internationally accepted. I understand the Taiwan situation is unfortunately an exception to this "generally". http://en.wikipedia.org/wiki/ISO_3166-2:TW and http://en.wikipedia.org/wiki/ISO_3166-1 have more details...

          It's possible to change the language strings in /lang/.../countries.php locally. I am aware that the translations are not following the original string very closely (the zh_cn translation is "chinese taiwan", the zh_tw translation is "taiwan", and others are equally different).

          Any opinion on this from other Moodlers?

          Chen cathynina added a comment -

          Hi,
          If any possible,can you open the codes for us to edit the country names?
          Or coulde you select other country lists not from ISO?
          The ISO country list cause a lot of issues.
          Not only me to reply this issues.
          I traced the provious requests and some people have the same situation.
          Thanks for your help.

          Mathieu Petit-Clair added a comment -

          Hmm.. As far as I know, this is the first (or second?) issue since we updated the list... Can you be more specific about this? What other country list is there to use? (I'm open to suggestions, it has to be a really good one to beat ISO!)

          As I said, you can modify the files under /lang/[langcode]/countries.php and modify the names to anything you see fit.

          Chen cathynina added a comment -

          Yes, I did some research.
          The fowllowing is a discussion from the forums of the general problem in the moodle

          Country names by Pete MacKichan - Tuesday, 29 July 2008, 06:51 AM
          Hi,
          I am wondering if there is any way to edit the country names that are shown as options in the profile. There are options that people might like to be able to select that do not appear on the list. For example:-
          Scotland, Wales, Euskadi, Taiwan (without "province of China"), Aetoroa, etc.
          I do feel students should be able to select options that they feel comfortable with - for example students in Scotland would probably not want to choose United Kingdom. I am wondering which file in my Moodle installation I could edit to add other options. Or are these options being provided by an external library on my server? In which case, is there any way I could call an additional list of options to be merged with it when the user edits their profile?
          Thanks,
          Pete

          Mathieu Petit-Clair added a comment -

          That seems like a quote out of http://moodle.org/mod/forum/discuss.php?d=102222 ... I think the answer on that discussion was good: you can edit the file locally.

          What other country lists could we use that would be better than ISO?

          Chen cathynina added a comment -

          Sorry, I am not a expert of computer.
          But I did some research.

          The Internet Assigned Numbers Authority (IANA) assigns two-letter codes for country-coded top-level domains in Internet addresses. These codes are the same as the ISO 2-alpha codes in nearly all cases.

          http://www.iana.org/domains/root/db/

          Is it Ok?

          Chen cathynina added a comment -

          I research more information.

          FIPS 10: Countries, Dependencies, Areas of Special Sovereignty, and Their Principal Administrative Divisions (FIPS 10) is maintained by the Office of Targeting and Transnational Issues, National Geospatial-Intelligence Agency, and published by the National Institute of Standards and Technology (Department of Commerce). FIPS 10 codes are intended for general use throughout the US Government, especially in activities associated with the mission of the Department of State and national defense programs.
          http://en.wikipedia.org/wiki/List_of_FIPS_country_codes

          STANAG 1059: Letter Codes for Geographical Entities (8th edition, 2004) is a Standardization Agreement (STANAG) established and maintained by the North Atlantic Treaty Organization (NATO/OTAN) for the purpose of providing a common set of geo-spatial identifiers for countries, territories, and possessions. The 8th edition established trigraph codes for each country based upon the ISO 3166-1 alpha-3 character sets. These codes are used throughout NATO.
          http://en.wikipedia.org/wiki/List_of_NATO_country_codes

          Those list are correct to show Taiwan's name.
          Taiwan, Province of China" has been made with pressure from the People's Republic of China over the political status of Taiwan.

          Thank you.

          Mathieu Petit-Clair added a comment - - edited

          As written on this page, http://www.iana.org/domains/root/cctld/ IANA also follows the two-letter subset of ISO 3166, so it's not really a different list...

          The NATO list includes a number of non-country entries (like "europe") that would create problems of their own. The FIPS list also includes a number of entries (the case of the Paracel Islands is of particular interest to you) that could be problematic. I don't think either (US-specific) list would be better than the current (international) ISO list.

          Chen cathynina added a comment -

          Sorry, I don't know about country codes very well.
          But I registered to other system or webs such google, yahoo...
          They did not have this problem.
          How they make it?
          How they get the country code?

          Chen cathynina added a comment - - edited

          It seems that any country code has its problem.
          Could you offer two or more types country codes for people to select?
          People can select the country codes to fit their need.
          Thank you.

          Martin Dougiamas added a comment -

          Just noting here that I just renamed 'Taiwan (Province of China)' to 'Taiwan' in HEAD and 1.9.

          Our rationale before was to stick to the ISO-3166 standard no matter what, since we don't want to get involved in territorial issues. However, in this case no information is lost and it would make a lot of people happier (and no one unhappy, I think), so I'm going to make one exception here. Hope it's not a can of worms!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: